×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    May 2007
    Location
    USA
    Posts
    120

    Exclamation Pointer to obsolete nmake in S60/5e C++ DevLib v2.0

    Please see: S60 5th Edition C++ Developer's Library v2.0 > Testing > Testing your software > Setting up a test project > Tool setup.

    Requirement #4 on that page is nmake and a link is provided. From the URL, it seems that version of nmake seems like was for Windows95!? When I attempt to install that on Vista x64, I get an error:

    The version of this file is not compatible with the version of Windows you're running. Check your computer's system information to see whether you need an x86 (32-bit) or x64 (64-bit) version of the program, and then contact the software publisher.

    These days nmake is provided with the .NET framework, and that is what I ended up using. Unfortunately I was not able to successfully complete the chapter (see my post this thread) and I cannot determine the cause for it - the version of nmake may be one of the problems but I don't know.

    Please update the documentation with current information about nmake for x86 & x64 Windows OSes, and please verify that the tutorial can be completed as described. Thanks.
    --Himanshu
    Nokia N8-00 (Symbian Belle, NAM RM-596)
    Nokia 5800 XpressMusic (S60 5th Ed., NAM RM-428, v51.2.007)
    S/w: ADT v1.4 + S60 5.0 SDK on Win7 x64

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Posts
    1,213

    Re: Pointer to obsolete nmake in S60/5e C++ DevLib v2.0

    Thank you for your feedback. The text will be corrected in the next library release.

    Seppo
    Forum Nokia

  3. #3
    Registered User
    Join Date
    May 2007
    Location
    USA
    Posts
    120

    Re: Pointer to obsolete nmake in S60/5e C++ DevLib v2.0

    Hello Seppo,

    v2.1 has no changes on this Tool setup page.
    --Himanshu
    Nokia N8-00 (Symbian Belle, NAM RM-596)
    Nokia 5800 XpressMusic (S60 5th Ed., NAM RM-428, v51.2.007)
    S/w: ADT v1.4 + S60 5.0 SDK on Win7 x64

  4. #4
    Registered User
    Join Date
    May 2007
    Location
    USA
    Posts
    120

    Re: Pointer to obsolete nmake in S60/5e C++ DevLib v2.0

    I'm wondering if nmake is requried at all for building unit tests as described in the tutorial. Can anyone confirm?
    --Himanshu
    Nokia N8-00 (Symbian Belle, NAM RM-596)
    Nokia 5800 XpressMusic (S60 5th Ed., NAM RM-428, v51.2.007)
    S/w: ADT v1.4 + S60 5.0 SDK on Win7 x64

Similar Threads

  1. FATAL ERROR - Applet 17 with certain png's
    By OneNineStudios in forum Mobile Java Media (Graphics & Sounds)
    Replies: 2
    Last Post: 2008-12-17, 13:11
  2. Problem with GCCE build in Carbide.vs
    By raffaelbechara in forum Symbian
    Replies: 6
    Last Post: 2008-10-20, 16:06
  3. stupid error!
    By bojkar in forum Symbian
    Replies: 1
    Last Post: 2006-12-14, 05:47
  4. Linux driver in RedHat 7.3
    By nsolhjoo in forum Multimodecards
    Replies: 0
    Last Post: 2003-10-24, 17:04

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×