×

Discussion Board

Page 1 of 4 1234 LastLast
Results 1 to 15 of 49
  1. #1
    Nokia Developer Moderator
    Join Date
    May 2007
    Location
    21.46 N 72.11 E
    Posts
    3,796

    PyS60 [1.9.6] Tests and Feedback

    Hi,

    Quote Originally Posted by tvijayan View Post

    - The modules in the base runtime is more refined and hence the size of application SIS, created using PyS60 Application Packager is reduced.
    Well at least the size of Python_1.9.6.sis is increased to 3.32 Mb from the past 2.83MB. Still baffled how the app size would decrease. Need to try it practically.


    PS: Please replace sticky 1.9.5 feedback thread with this one.
    Pankaj Nathani
    www.croozeus.com

  2. #2
    Nokia Developer Moderator
    Join Date
    May 2007
    Location
    21.46 N 72.11 E
    Posts
    3,796

    Re: PyS60 [1.9.6] Tests and Feedback

    From the release notes,
    4215 - default.py cannot load .pyc files
    Could someone shed more light on this? Does it mean that I can no longer call .pyc from a PyS60 application that I created manually by 1.9.6 ensymble?

    Wondering,
    Pankaj Nathani
    www.croozeus.com

  3. #3
    Regular Contributor
    Join Date
    Oct 2007
    Posts
    114

    Re: PyS60 [1.9.6] Tests and Feedback

    Quote Originally Posted by croozeus View Post
    From the release notes,


    Could someone shed more light on this? Does it mean that I can no longer call .pyc from a PyS60 application that I created manually by 1.9.6 ensymble?

    Wondering,
    Hey, that is the bug summary. It is fixed in 1.9.6 and that means you CAN load pyc now.
    import antigravity

  4. #4
    Nokia Developer Moderator
    Join Date
    May 2007
    Location
    21.46 N 72.11 E
    Posts
    3,796

    Re: PyS60 [1.9.6] Tests and Feedback

    Quote Originally Posted by ashwinurao View Post
    Hey, that is the bug summary. It is fixed in 1.9.6 and that means you CAN load pyc now.
    Alright! Thanks, understood
    Pankaj Nathani
    www.croozeus.com

  5. #5
    Nokia Developer Moderator
    Join Date
    May 2007
    Location
    21.46 N 72.11 E
    Posts
    3,796

    Re: PyS60 [1.9.6] Tests and Feedback

    Please add 1.9.6 version at maemo garage (bug sumbitting), while submitting a new bug. For now I can select only till 1.9.5
    Pankaj Nathani
    www.croozeus.com

  6. #6
    Nokia Developer Moderator
    Join Date
    May 2007
    Location
    21.46 N 72.11 E
    Posts
    3,796

    Re: PyS60 [1.9.6] Tests and Feedback

    Tested on Nokia E50: The PyS60 shell takes 5 seconds to launch. Is that normal?
    Pankaj Nathani
    www.croozeus.com

  7. #7
    Nokia Developer Champion
    Join Date
    Feb 2008
    Location
    Ahmedabad, Gujarat, India
    Posts
    3,852

    Re: PyS60 [1.9.6] Tests and Feedback

    Quote Originally Posted by croozeus View Post
    Tested on Nokia E50: The PyS60 shell takes 5 seconds to launch. Is that normal?
    hello all

    same is the case with my N96.

    Regards
    Gaba88

  8. #8
    Nokia Developer Moderator
    Join Date
    May 2007
    Location
    21.46 N 72.11 E
    Posts
    3,796

    Re: PyS60 [1.9.6] Tests and Feedback

    Nokia E50: V 07.36.0.0 RM-171
    Nokia N95 8GB: 20.0.016 RM-320

    On interactive console,
    >>import scriptext

    ImportError: No module named scriptext
    Would report this as a bug !
    Pankaj Nathani
    www.croozeus.com

  9. #9
    Regular Contributor
    Join Date
    Jul 2007
    Location
    Eindhoven, the Netherlands
    Posts
    187

    Re: PyS60 [1.9.6] Tests and Feedback

    Hi Pankaj,

    As far as I know, scriptext was not going to be supported on 3rdFp1.
    I'm not sure about the E50, but the N95 runs 3rdFp1, so scriptext is not supposed
    to work there.

    Mark.

  10. #10
    Nokia Developer Expert
    Join Date
    Apr 2007
    Posts
    131

    Re: PyS60 [1.9.6] Tests and Feedback

    Yes, scriptext module is supported only from 3rdEd Fp2 devices onwards.

  11. #11
    Nokia Developer Moderator
    Join Date
    May 2007
    Location
    21.46 N 72.11 E
    Posts
    3,796

    Re: PyS60 [1.9.6] Tests and Feedback

    Too many devices, works on 6220c and N97 fine
    Pankaj Nathani
    www.croozeus.com

  12. #12
    Nokia Developer Champion
    Join Date
    Feb 2008
    Location
    Ahmedabad, Gujarat, India
    Posts
    3,852

    Re: PyS60 [1.9.6] Tests and Feedback

    hello PyS60 Team

    Here something strange is happening. First i installed the PyS60 1.9.6 in my N96 it was smooth but as i have already mentioned in the thread the shell took a time to start and the performance speed of the device was also slowed down.

    so i uninstalled the runtime,scriptshell and tried to install them again.

    Now while installing the runtime i get a error i.e

    "Unable to install a protected application from an untrusted supplier"
    Where i am going wrong as the installation was smooth in the first time.

    Can anybody confirm this on another N96.

    Regards
    Gaba88

  13. #13
    Registered User
    Join Date
    Aug 2005
    Posts
    13

    Re: PyS60 [1.9.6] Tests and Feedback

    Hmm, i also got the same error on my first installation of Python 1.9.6 on the E75
    Before installation, i already removed the 1.9.5 PythonShellScript and Python runtime.. are there other packages that needs to be removed?

  14. #14
    Nokia Developer Champion
    Join Date
    Feb 2008
    Location
    Ahmedabad, Gujarat, India
    Posts
    3,852

    Re: PyS60 [1.9.6] Tests and Feedback

    Quote Originally Posted by kohchunk View Post
    Hmm, i also got the same error on my first installation of Python 1.9.6 on the E75
    Before installation, i already removed the 1.9.5 PythonShellScript and Python runtime.. are there other packages that needs to be removed?
    hello kohchunk

    this seems to be the problem with only 3rd edition FP2 devices only as the release is running fine on my N95.

    Regards
    Gaba88

  15. #15
    Super Contributor
    Join Date
    Mar 2003
    Location
    Espoo, Finland
    Posts
    976

    Re: PyS60 [1.9.6] Tests and Feedback

    [#4216] sys.exit() doesn't exit python
    https://garage.maemo.org/tracker/ind...=854&atid=3201

    Please clarify WHICH release will contain this fix. Now reopening, because latest release 1.9.6 still crashes:

    Code:
    Traceback (most recent call last):
     File "default.py", line 103, in menu_action
      f()
     File "default.py", line 70, in query_and_exec
      script_namespace.namespace)
     File "e:\data\python\default.py", line 24, in
    <module>
      sys.exit()
    SystemExit
    ...well, I would reopen or resubmit or something, if I could do so. Now all I can do is to make this comment and hope that someone would notice it...

    Cheers,

    --jouni

Similar Threads

  1. PyS60 [1.9.5] Tests and Feedback
    By marcelobarrosalmeida in forum Symbian
    Replies: 32
    Last Post: 2009-06-22, 16:40
  2. PyS60[1.9.4] Tests and Feedback
    By tvijayan in forum Symbian
    Replies: 69
    Last Post: 2009-05-22, 00:53
  3. [PyS60 1.9.3] Tests and Feedback
    By croozeus in forum Symbian
    Replies: 24
    Last Post: 2009-04-17, 20:57
  4. [PyS60 1.9.0] Tests and Feedback
    By cyke64 in forum Symbian
    Replies: 107
    Last Post: 2009-02-18, 20:10
  5. Feedback on new document "Avoiding Common Failures in Symbian Signed tests"
    By mgroeber9110 in forum Feedback - Nokia Developer Services & Infrastructure
    Replies: 4
    Last Post: 2007-03-29, 07:31

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×