×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Registered User
    Join Date
    Mar 2004
    Posts
    27

    Problem when loading c module on 6220 (KErrNotFound)

    I wrote a pys60 app that works on N95 and various other phones but when I start it on the 6220 classic it crashes.

    I traced the crash to the loading of an external library (.pyd):

    File "c:\resource\myutil.py", line 5, in ?
    _myutil= imp.load_dynamic('_myutil', 'c:\\sys\\bin\\_myutil.pyd')
    SymbianError: [Errno -1] KErrNotFound

    I am using pys60 1.4.5, but I also tried using 1.4.4 with the same effects.

    Any ideas why it doesn't work on the 6220 classic?

    thx
    Stefan
    Want to find out what is in your sis?
    Go to www.whatisinmysis.com!

    I've used it to debug the content, capabilities and signing of a sis :)

  2. #2
    Nokia Developer Champion
    Join Date
    Feb 2008
    Location
    Ahmedabad, Gujarat, India
    Posts
    3,852

    Re: Problem when loading c module on 6220 (KErrNotFound)

    Quote Originally Posted by sliver33 View Post
    I wrote a pys60 app that works on N95 and various other phones but when I start it on the 6220 classic it crashes.

    I traced the crash to the loading of an external library (.pyd):

    File "c:\resource\myutil.py", line 5, in ?
    _myutil= imp.load_dynamic('_myutil', 'c:\\sys\\bin\\_myutil.pyd')
    SymbianError: [Errno -1] KErrNotFound

    I am using pys60 1.4.5, but I also tried using 1.4.4 with the same effects.

    Any ideas why it doesn't work on the 6220 classic?

    thx
    Stefan
    hello silver33

    i guess this is indeed strange, once i also faced this sort of situation and what i have done is uninstalled the runtime and shell and installed it again, that clicked for me.

    Can't spot out the exact problem if you are using the same PyS60 realease.

    Good Luck!!

  3. #3
    Nokia Developer Champion
    Join Date
    Feb 2008
    Location
    Ahmedabad, Gujarat, India
    Posts
    3,852

    Re: Problem when loading c module on 6220 (KErrNotFound)

    hi again

    i forget one thing 6220 classic is a 3rd FP2 device and AFAIK 1.4.5 dont have esact binaries for that. May that be the reason.

    Have you tested the script in anyother 3rd FP2 device??

  4. #4
    Registered User
    Join Date
    Mar 2004
    Posts
    27

    Re: Problem when loading c module on 6220 (KErrNotFound)

    Thx for the response gaba88.

    Unfortunately I don't have a different 3rd fp2 device at hand.

    So it might only work with python 1.9 on 3rd fp2 device? I just tried to install version 1.9.3 but after that my app won't even start. I guess I also have to update my app sis (build with ensymble) to use the new package mechanism, right?
    Want to find out what is in your sis?
    Go to www.whatisinmysis.com!

    I've used it to debug the content, capabilities and signing of a sis :)

  5. #5
    Nokia Developer Champion
    Join Date
    Feb 2008
    Location
    Ahmedabad, Gujarat, India
    Posts
    3,852

    Re: Problem when loading c module on 6220 (KErrNotFound)

    Quote Originally Posted by sliver33 View Post
    So it might only work with python 1.9 on 3rd fp2 device? I just tried to install version 1.9.3 but after that my app won't even start. I guess I also have to update my app sis (build with ensymble) to use the new package mechanism, right?
    yes you have to make the new sis using the application packager that comes with the PyS60 1.9.x releases.

    Feel free to post any trouble you are facing with the application packager.

    Regards
    Gaba88

  6. #6
    Registered User
    Join Date
    Mar 2004
    Posts
    27

    Re: Problem when loading c module on 6220 (KErrNotFound)

    Ok, I downloaded pys60 1.9.6 installed the sdk and the runtime on the phone. Jumped over some obstacles when building with the new ensymble and now I got to following problem. Everytime I want to load my pyd module I get the following error:

    ImportError: dlopen: Load failed

    on this line:

    Code:
    _bdriverutil = imp.load_dynamic('_bdriverutil','c:\\sys\\bin\\kf_bdriverutil.pyd')

    Btw, Thanks gaba88, for all the help so far.
    Want to find out what is in your sis?
    Go to www.whatisinmysis.com!

    I've used it to debug the content, capabilities and signing of a sis :)

  7. #7
    Registered User
    Join Date
    Jul 2009
    Posts
    11

    Re: Problem when loading c module on 6220 (KErrNotFound)

    Hi silver33,

    Did you manage to solve your problem?
    I think I have a similar one in a library built for 1.4.x which I cannot install in my 3rd FP2 mobile...

    Many thanks in advance

  8. #8
    Registered User
    Join Date
    Mar 2004
    Posts
    27

    Re: Problem when loading c module on 6220 (KErrNotFound)

    I actually did today

    The problem was the library itself. I used the bluetooth api which changed for 3rd fp2 devices and the old version isn't available on newer devices.

    I hope that helps.
    Sliver
    Want to find out what is in your sis?
    Go to www.whatisinmysis.com!

    I've used it to debug the content, capabilities and signing of a sis :)

Similar Threads

  1. Problem Signing Misoalarm Module
    By rishabhgupta in forum Symbian
    Replies: 8
    Last Post: 2008-06-03, 16:29
  2. Replies: 4
    Last Post: 2008-05-22, 08:50
  3. The problem about the audio module of the game engine
    By vincent.lee in forum Symbian Media (Closed)
    Replies: 2
    Last Post: 2008-03-15, 07:22
  4. N-90 Mechanical Problem Turning camera Module
    By ALTheo in forum General Development Questions
    Replies: 1
    Last Post: 2006-04-06, 18:41
  5. Problem in loading image into WAP emulator through jsp
    By gchuaay in forum Browsing and Mark-ups
    Replies: 0
    Last Post: 2002-05-15, 12:21

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×