×

Discussion Board

Page 2 of 2 FirstFirst 12
Results 16 to 30 of 30
  1. #16
    Regular Contributor
    Join Date
    Jan 2009
    Posts
    74

    Re: TCommDbConnPref - Invalid Format

    Quote Originally Posted by nstapleton View Post
    Resolved the problem.

    Nothing was being written to the ErrRd file.

    Sorry guys for time wasting; It was an error in my resource file causing the crash.
    Hi,

    I am having the same problem. can u kindly tell me whats wrong with resource file?

  2. #17
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,344

    Re: TCommDbConnPref - Invalid Format

    Quote Originally Posted by sathiyapriyanm View Post
    Hi,

    I am having the same problem. can u kindly tell me whats wrong with resource file?
    If you have the same problem then the solution proposed should have fixed your too. Note that ErrRd file does not require to contain any data. It will remain empty forever but its existence will help you in getting panic code. So you can just let it be empty.

    Now coming to the original problem, can you explain what did you do and what did fail, so far?
    Nokia Developer Wiki Moderation team

  3. #18
    Regular Contributor
    Join Date
    Jan 2009
    Posts
    74

    Re: TCommDbConnPref - Invalid Format

    Quote Originally Posted by kiran10182 View Post
    If you have the same problem then the solution proposed should have fixed your too. Note that ErrRd file does not require to contain any data. It will remain empty forever but its existence will help you in getting panic code. So you can just let it be empty.

    Now coming to the original problem, can you explain what did you do and what did fail, so far?
    Hi Thanks for the reply...

    I am new to symbian. i have imported the HTTPClientExample and it runs fine for both get and post.

    Now i am trying to implement it in my program, i have copied the clientengine.h and .cpp to my program and fixed the lib issues and what i am try to do is while clicking a menu i am simply sending the www.google.com in the IssueHTTPGetL..but my code gets crashed in the following line kindly help me..

    // Start connection
    User::LeaveIfError(iConnection.Start(connectPref));

    after this line my emulator closing..

  4. #19
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,344

    Re: TCommDbConnPref - Invalid Format

    Quote Originally Posted by sathiyapriyanm View Post
    after this line my emulator closing..
    Apply this: http://wiki.forum.nokia.com/index.ph...ded_panic_code

    Then set the epoc.exe(Emulator) in the debug configuration so that your emulator will alive and you could see the panic code. Check this: http://wiki.forum.nokia.com/index.ph...arbide.c%2B%2B
    Nokia Developer Wiki Moderation team

  5. #20
    Regular Contributor
    Join Date
    Jan 2009
    Posts
    74

    Re: TCommDbConnPref - Invalid Format

    Quote Originally Posted by kiran10182 View Post
    Apply this: http://wiki.forum.nokia.com/index.ph...ded_panic_code

    Then set the epoc.exe(Emulator) in the debug configuration so that your emulator will alive and you could see the panic code. Check this: http://wiki.forum.nokia.com/index.ph...arbide.c%2B%2B
    Thank you very much for this tip...now its showing the error infos.....

    Its shows,

    Application Closed:
    Test1
    Cone14

    Test1 is my application name...can you able to figure out the problem now...thank you.

  6. #21
    Regular Contributor
    Join Date
    Jan 2009
    Posts
    74

    Re: TCommDbConnPref - Invalid Format

    Quote Originally Posted by sathiyapriyanm View Post
    Thank you very much for this tip...now its showing the error infos.....

    Its shows,

    Application Closed:
    Test1
    Cone14

    Test1 is my application name...can you able to figure out the problem now...thank you.
    hi,
    It seems that cone14 is because of content missing in .rss file..As i said before, i am using the httpclientexample's clientengine.h and .cpp, is that i have to copy the .rss of this project to my project???is that the right thing?

  7. #22
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,344

    Re: TCommDbConnPref - Invalid Format

    Quote Originally Posted by sathiyapriyanm View Post
    hi,
    It seems that cone14 is because of content missing in .rss file..As i said before, i am using the httpclientexample's clientengine.h and .cpp, is that i have to copy the .rss of this project to my project???is that the right thing?
    You need to give more information. Which resources are you using from that example? If yes, then you need to include those resources in your application too.
    Nokia Developer Wiki Moderation team

  8. #23
    Regular Contributor
    Join Date
    Jan 2009
    Posts
    74

    Re: TCommDbConnPref - Invalid Format

    Quote Originally Posted by kiran10182 View Post
    You need to give more information. Which resources are you using from that example? If yes, then you need to include those resources in your application too.
    hi....actually i am simply using the .h and the .cpp file as i mentioned before. i dont know wt else i have to do.

    can you kindly send me a sample project for posting some string in http??? its very urgent..kindly send it to sathiyapriyanm@yahoo.co.uk...thank you very much...

  9. #24
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,344

    Re: TCommDbConnPref - Invalid Format

    If I remember it correctly, that example uses some resources for wait dialog or something else. You can remove the occurrences of such a dialog which requires some resource which you do not have.

    Anyways check this example: S60 Platform: HTTP Client Example
    Nokia Developer Wiki Moderation team

  10. #25
    Regular Contributor
    Join Date
    Jan 2009
    Posts
    74

    Re: TCommDbConnPref - Invalid Format

    Quote Originally Posted by kiran10182 View Post
    If I remember it correctly, that example uses some resources for wait dialog or something else. You can remove the occurrences of such a dialog which requires some resource which you do not have.

    Anyways check this example: S60 Platform: HTTP Client Example
    Yes you are right. I am creating my project by making use of the S60 Platform: HTTP Client API Example v2.1 project..But i was not able to figure out that wait dialog or which resource is need for this program. Actually it should be in ClientEngine.h or ClientEngine.cpp....i dont know where it is..can you kindly help me to figure it out..plzz

  11. #26
    Regular Contributor
    Join Date
    Jan 2009
    Posts
    74

    Re: TCommDbConnPref - Invalid Format

    Quote Originally Posted by sathiyapriyanm View Post
    Yes you are right. I am creating my project by making use of the S60 Platform: HTTP Client API Example v2.1 project..But i was not able to figure out that wait dialog or which resource is need for this program. Actually it should be in ClientEngine.h or ClientEngine.cpp....i dont know where it is..can you kindly help me to figure it out..plzz
    or can i send you my sample?

  12. #27
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,344

    Re: TCommDbConnPref - Invalid Format

    Quote Originally Posted by sathiyapriyanm View Post
    or can i send you my sample?
    Yes please. Post your header(ClientEngine.h) and source file(ClientEngine.cpp) here.
    Nokia Developer Wiki Moderation team

  13. #28
    Regular Contributor
    Join Date
    Jan 2009
    Posts
    74

    Smile Re: TCommDbConnPref - Invalid Format

    Quote Originally Posted by kiran10182 View Post
    Yes please. Post your header(ClientEngine.h) and source file(ClientEngine.cpp) here.
    Thank You very much for u great help!!!!!!!!!!!!!! Finally i solved the prob with your help kiran..Thank you so much...........

  14. #29
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,344

    Re: TCommDbConnPref - Invalid Format

    Quote Originally Posted by sathiyapriyanm View Post
    Thank You very much for u great help!!!!!!!!!!!!!! Finally i solved the prob with your help kiran..Thank you so much...........
    You are welcome.
    Nokia Developer Wiki Moderation team

  15. #30
    Registered User
    Join Date
    Jul 2012
    Posts
    43

    Re: TCommDbConnPref - Invalid Format

    Quote Originally Posted by sathiyapriyanm View Post
    Thank You very much for u great help!!!!!!!!!!!!!! Finally i solved the prob with your help kiran..Thank you so much...........
    What were the changes made.. please mention that also..
    Iam also facing the same error

Similar Threads

  1. Error in packaging process :(
    By a-eqla3 in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2008-07-24, 20:33
  2. Replies: 7
    Last Post: 2006-09-20, 23:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×