×

Discussion Board

Results 1 to 9 of 9
  1. #1
    Regular Contributor
    Join Date
    Mar 2009
    Posts
    132

    [moved] Error in ondevice debugging

    Hi friends,
    I m trying to debugg my application on N91(3rd edition device).But it(pc) can't connect with device.I am using carbide2.0 and trk1.4.0.its giving error i.e
    Target request failed: TRKProtocolPlugin : Unable to open communications port (Port may be used by another application or selected port may not be available.).
    After that it given message "serial port connection service is not avilable".

    As trying in manually,Where i found that serial port services option is disabled(for N91).But i have tried in nokia 3110c where this is enabled .
    So here my question is it device specific?
    The above errors comes for this issue or another probs?
    Please help me.
    Thanks in advance,
    sk

  2. #2
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Error in ondevice debugging

    I suggest you check you firmware for upgrades and install the right version of TRK

  3. #3
    Regular Contributor
    Join Date
    Mar 2009
    Posts
    132

    Re: Error in ondevice debugging

    Thanks.Let me do these things.But i m quite sure,have installed right trk sis file.

  4. #4
    Registered User
    Join Date
    Jul 2008
    Posts
    10

    Re: Error in ondevice debugging

    I think you need to check the port you have selected and the port to which device is connected same.
    and install a s60_3_0_app_trk_2_8_7 this trk.

  5. #5
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,689

    Re: Error in ondevice debugging

    2.8.7 is past tense too. Current TRK versions are at least 3.0.9

  6. #6
    Regular Contributor
    Join Date
    Mar 2009
    Posts
    132

    Re: Error in ondevice debugging

    i have instlled this sis file(s60_3_0_app_trk_3_0_8.sisx) on device(N(91).Thats i got below given path
    C:\Program Files\Nokia\Carbide.c++ v2.0\plugins\com.nokia.carbide.trk.support_1.4.0.014\trk\s60
    is it right sis for N91?

  7. #7
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,689

    Re: Error in ondevice debugging

    Oh, now I see where "1.4.0" comes from. Yes, although there is 3.0.9, which is more recent (so you can still consider updating Carbide), 3.0.8 is also expected to work on an N91. The S60_3_0... is correct.
    Now, I have checked, and I do not really understand what (or why) you write about 3110c, that is an S40 device.
    Are you following these steps:
    - connect device to PC
    - select PC Suite mode when asked
    - (does PC Suite recognize your device?)
    - start TRK on device (check its Settings, is it USB and a number - preferably 1 - ?)
    - (if Status says "Disconnected", use "Connect" from the menu)
    - open Run/Debug Configurations... in Carbide
    - select "Symbian OS Application TRK"
    - create a new configuration or modify an old one:
    --- connection should be USB (not Bluetooth, not Serial)
    --- in Connection Settings you should search for a Serial Port, which has N91 in its name ("COMx - Nokia N91 USB" or something similar - where x can be a really high number sometimes)
    --- Device OS is usually 3.0.0 by default, and it is OK for your N91
    - click on Initiate Service Testing
    - (what happens?)

  8. #8
    Super Contributor
    Join Date
    Jul 2008
    Posts
    2,020

    Re: Error in ondevice debugging

    What version of Carbide are you on? Check for updates first - I know it takes an hour or more, but helps!
    The lines above are the best I have to offer.If anyone of you is of more advanced knowledge, I ask for your patience and understanding! - unknown arab poet
    http://www.tamoggemon.com - Symbian blog - Windows Phone blog
    My other blogs:
    webOS blog iPhone blog BlackBerry blog Samsung bada blog Android blog

  9. #9
    Regular Contributor
    Join Date
    Mar 2009
    Posts
    132

    Re: [moved] Error in ondevice debugging

    Thanks a lot wizad_hu.Now its working fine.

Similar Threads

  1. [moved] Debugging two executables on emulator simultaneously
    By suresh.venkata in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2009-07-26, 14:44
  2. [Moved] Can't load debugging symbols (on-device)
    By Theril in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 2
    Last Post: 2008-07-02, 11:55
  3. [moved] how to disable stack or disassembly view during debugging
    By manjunathcv in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2008-06-26, 21:36
  4. Replies: 4
    Last Post: 2008-05-29, 21:30
  5. OnDevice Debugging Bluetooth Device
    By anoopd in forum Symbian Tools & SDKs
    Replies: 10
    Last Post: 2007-08-16, 14:19

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×