×

Discussion Board

Results 1 to 10 of 10
  1. #1
    Registered User
    Join Date
    Aug 2008
    Location
    Ireland
    Posts
    29

    CAknTextQueryDialog on device erro Menu: Feature not supported

    Hi,
    I have written a dialog class which inherits from CAknTextQueryDialog.
    It all runs fine on the emulator.
    However when I install on the device and try to run the app I get a "Menu: Feature not supported" error.

    Thinking that I have done something wrong I then compiled and installed the BrctlSampleApp that is part of the SDK examples. This also has a class which inherits from CAknTextQueryDialog. this results in the exact same problem.

    Has anyone any ideas? Perhaps there are libraries missing on the device.

    I am using the S60 5th edition SDK. the devices that I have installed on are pre-s60 V5 - however this has never casued me problems in the past.

    Regards,
    Brian

  2. #2
    Super Contributor
    Join Date
    Aug 2005
    Location
    india
    Posts
    2,078

    Re: CAknTextQueryDialog on device erro Menu: Feature not supported

    HI,

    i guess you dont have the required capability of the application that you are trying to install.

    Regards,
    Mateen Maldar
    "Whatever the mind can conceive and believe, the mind can achieve"

  3. #3
    Registered User
    Join Date
    Nov 2008
    Location
    Mumbai-India
    Posts
    379

  4. #4
    Nokia Developer Champion
    Join Date
    Jun 2008
    Location
    Noida,India
    Posts
    4,019

    Re: CAknTextQueryDialog on device erro Menu: Feature not supported

    hi have you added avkon.lib in your mmp file.

  5. #5
    Super Contributor
    Join Date
    Oct 2007
    Location
    જુનાગઢ - India
    Posts
    3,034

    Re: CAknTextQueryDialog on device erro Menu: Feature not supported

    Quote Originally Posted by vineet.jain View Post
    hi have you added avkon.lib in your mmp file.
    Missing .lib will cause compile time error, not run-time error.

    @brian.egan:

    check Epocwind.out, if any capability is missing.

    Also go through link suggested by pandhari.gorde.

  6. #6
    Registered User
    Join Date
    Aug 2008
    Location
    Ireland
    Posts
    29

    Re: CAknTextQueryDialog on device erro Menu: Feature not supported

    Hi,
    Thanks for the reply.

    1. If I did not include avkon.lib then it would not compile. It runs fine on the emulator.
    2. The Nokia BrCtlSampleApp does not require a very high level of capabilities. Our application has quite a lot of capabilities and all that should be needed for this.

    It just strikes me as strange that I am having the same problem with the brCtlSample App which has been realease with many SDKs to date. Has anyone else ever had problems installing this application to the device?

    By the way the device that I have installed to is a 6220 and an N73.

    Thanks,
    Brian

  7. #7
    Registered User
    Join Date
    Aug 2008
    Location
    Ireland
    Posts
    29

    Re: CAknTextQueryDialog on device erro Menu: Feature not supported

    Have found the problem.

    It seems to be that there is some sort of binary compatability issue somewhere between the S60V5 SDK and the S603rd FP2 - most likely in the base Dialog libraries.

    I compiled using the BrCtlSampleApp using S603rd FP2 and installed to my 6220 Classic and it ran fine. However compiling using S60V5 SDK and installing to 6220 classic will not run.

    It is quite strange to see such compatibility issues with such core libraries and have only seen this before with less frequently used libraries.
    Last edited by brian.egan; 2009-07-09 at 17:32.

  8. #8
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,684

    Re: CAknTextQueryDialog on device erro Menu: Feature not supported

    Are you aware of the concept of 'compatibility'? Try running quake3.exe on MS-DOS 5.0 to find out some details - it is a .exe after all.

  9. #9
    Registered User
    Join Date
    Aug 2008
    Location
    Ireland
    Posts
    29

    Re: CAknTextQueryDialog on device erro Menu: Feature not supported

    Sorry I am not sure what your comment is meant to mean.

    You will find that compiling most basic applications on later SDKs should run on older (all Symbian 9.0 +) devices.
    CEikDialog/CAknDialog are core S60 classes and in gerneral these are always compatible.

  10. #10
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,684

    Re: CAknTextQueryDialog on device erro Menu: Feature not supported

    That 'should' should be may. You can not expect an N73 (more than 3 years old device, Symbian 9.1, S60 3rd noFP) to execute code built for less than 1 year old, touchscreen-based devices running Symbian 9.4, S60 5th edition.

    And that "always compatible" is better said as backwards compatible for the same reason.

Similar Threads

  1. Replies: 4
    Last Post: 2009-12-19, 15:35
  2. OpenIniFileLC Feature is not supported
    By sirurx in forum Symbian
    Replies: 0
    Last Post: 2003-07-30, 13:37
  3. nokia 7210 modem via IR doesn't work !
    By oussamaaiadi in forum PC Suite API and PC Connectivity SDK
    Replies: 1
    Last Post: 2003-03-06, 10:46
  4. Which is the best Nokia j2me supported device?
    By fbebic in forum Mobile Java General
    Replies: 1
    Last Post: 2002-07-11, 11:03

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×