×

Discussion Board

Results 1 to 8 of 8

Thread: problem

  1. #1
    Registered User
    Join Date
    Jul 2009
    Posts
    4

    problem

    When I run Carbide it just say "perl was not found on your PATH..." I have downloaded and installed activeperl. So, what I must do?

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,699

    Re: problem

    Check if it is accessible from a command prompt (just type "perl -v" for example). Note that if you happen to use Vista, it may cause some trouble with the installation (of Perl amongst other things). In this case search for vista in the Wiki, and you will find 1-2 articles about what you should check/modify and how.

  3. #3
    Registered User
    Join Date
    Jul 2009
    Posts
    4

    Re: problem

    http://wiki.forum.nokia.com/index.php/Windows_Vista

    I made that "PATH environment variable" section but it gives me same error. It would be nice if you can give me some links and tell me sections where to do fixes.

    When I installed S60_5th_Edition_SDK_v1_0_en everything where good. First that complained that I had missing perl but then I installed perl and after I succesfully installed S60_5th_Edition_SDK_v1_0_en. So, that took perl automaticly.

  4. #4
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,699

    Re: problem


  5. #5
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: problem

    Can you call Perl at command prompt or not? If you can then Carbide.c++ can too, if not then your fix of the %PATH% is not correct and you should have another look at it.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  6. #6
    Registered User
    Join Date
    Jul 2009
    Posts
    4

    Re: problem

    Yes, I can

    I did that and now it works

    - Install Active Perl version 5.6.1.638 only
    - Right click on the Carbide shortcut select the "Compatibility". Click the button "Run this program in compatibility mode for" Windows XP (Service Pack2)

    but it says like that

    "Carbide.C++ Version 2.0

    Carbide.C++ 2.0 Now supported Vista without adjustments. You can use OEM version WITHOUT needing to buy a licence. There will be people still using version 1.3 and therefore need the information below. New users and those with new projects should start using Carbide version 2.0 and the official Vista patches for S60 5th Edition. Follow the preparation instructions for Carbide v1.3 for Vista below and finally install Carbide.C++ 2.0 "

    1 problem more. everytime I start qt project it gives me error "Invalid project path: Include path not found (C:\Users\omistaja\Desktop\qtohjelma\tmp)". when I do tmp folder to C:\Users\omistaja\Desktop\qtohjelma\ folder then the problem is solved is that ok?
    Last edited by radawa; 2009-07-12 at 08:40.

  7. #7
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: problem

    Why have you configured your workspace to be on the Desktop? Vista is very protective with certain folders, the Desktop being one of them, so you should find yourself a more suitable location ...
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  8. #8
    Registered User
    Join Date
    Jul 2009
    Posts
    4

    Re: problem

    I have changed to C:\Symbian\Carbide\workspace\

Similar Threads

  1. STLPort namespace issue
    By yickhong in forum Open C/C++
    Replies: 0
    Last Post: 2009-04-09, 08:54
  2. SyncML link problem
    By samuel_ in forum Symbian
    Replies: 4
    Last Post: 2009-03-27, 08:02
  3. Problem with eglSwapBuffers and heap corruption
    By greatape in forum Symbian Media (Closed)
    Replies: 2
    Last Post: 2007-05-24, 03:35
  4. netcards - Problem with opening adapter
    By kernj in forum Symbian Tools & SDKs
    Replies: 5
    Last Post: 2007-01-10, 08:56
  5. Problem: S60 SDK for CW in PC with .NET
    By anttij in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2005-02-28, 11:36

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×