×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Regular Contributor
    Join Date
    Nov 2007
    Posts
    130

    Cannot connect phonon

    Hi,

    I configured qt with phonon and use phonon in my sample application. When i run the project and try to play a song, it doesn't play.

    In output log it shows warning like this..,

    WARNING: bool __thiscall Phonon::FactoryPrivate::createBackend(void) phonon backend plugin could not be loaded
    Phonon::createPath: Cannot connect Phonon::MediaObject(no objectName) to Phonon::AudioOutput(no objectName).

    What i should do to solve this problem. Kindly help

    Thanks in advance,
    Bala

  2. #2
    Regular Contributor
    Join Date
    Mar 2009
    Posts
    430

    Re: Cannot connect phonon

    Phonon is not yet available for S60. You can compile it but there is no working backend available ATM. See http://pepper.troll.no/s60prerelease...es-4.5.2-tower

  3. #3
    Regular Contributor
    Join Date
    Nov 2007
    Posts
    130

    Re: Cannot connect phonon

    Sorry I post it in a wrong one..

    Actually I am not using it for s60.. using qt4.4. beta

    Can you plz say where i can post it to get answer.

    Thanks 4 ur reply

  4. #4
    Regular Contributor
    Join Date
    Mar 2009
    Posts
    430

    Re: Cannot connect phonon

    You can search www.qtcentre.org.

  5. #5
    Registered User
    Join Date
    Jul 2009
    Posts
    16

    Re: Cannot connect phonon

    Hi,

    Qt 4.6.0 beta 1 includes a Phonon backend based on the MMF APIs. At present, this still lacks a few features (notably support for streaming media playback, provision of metadata to the client, and some video-related parameters such as aspect ratio and scaling mode). We are working on these, and plan to have them in place for the 4.6.0 release.

    Qt 4.6 will also ship with a binary-only delivery of a Helix-based Phonon backend.

    If you want to keep up to date with development of the MMF Phonon backend, you can use the following resources:

    You can also download daily snapshots (source, binaries and SIS files) of the complete Qt package from here.

    Best regards,
    Gareth

  6. #6
    Registered User
    Join Date
    Jul 2009
    Posts
    16

    Re: Cannot connect phonon

    Here is a quick update of the features which have been added to the Phonon backend in each release of Qt for Symbian:
    (Of course each release also has various bug fixes - full details are available in the database from http://bugreports.qt.nokia.com by searching for 'mmfphonon' as the component name).

    4.6.0
    • Audio and video playback from files, including metadata support


    4.6.1
    • Support for streaming playback
    • Playlist handling
    • Aspect ratio / scale mode handling
    • Fixed problems with video playback on some S60 3.2 devices


    4.6.2 (scheduled for release in week 7)
    • Enabled audio effects, if supported by the device


    Best regards,
    Gareth

  7. #7
    Regular Contributor
    Join Date
    Nov 2007
    Posts
    130

    Re: Cannot connect phonon

    Hi,

    I am using Qt4.6.1 for symbian and when i try to load mp3 song from server using URL, it is going into the error state and showing..

    "buffering clip failed unknown error(-39)"

    Is Qt4.6.1 for S60 doesn't support loading mp3 file from server?

    Or if any other way to load and play mp3 files from server using qt for s60 then kindly let me know.

    Regards,
    Bala
    Last edited by BalajiR; 2010-02-01 at 14:04. Reason: Updated

  8. #8
    Registered User
    Join Date
    Aug 2009
    Posts
    2

    Re: Cannot connect phonon

    Same problem even with the demo program "qmediaplayer", but message :

    "buffering clip failed : Could not connect"...

Similar Threads

  1. Replies: 7
    Last Post: 2009-03-21, 18:54
  2. Using Srial or USB to connect phoine to another device
    By blueriotriver in forum Mobile Java General
    Replies: 0
    Last Post: 2008-10-17, 05:19
  3. E70-1 BB connect BES with Lotus Notes
    By christophay in forum PC Suite API and PC Connectivity SDK
    Replies: 0
    Last Post: 2007-06-12, 10:12
  4. Emulated Nokia phone can not connect to bluegiga WT12 module
    By hwan122 in forum Bluetooth Technology
    Replies: 0
    Last Post: 2007-01-09, 01:05
  5. Connect Nokia 7650 Emulator to Internet via modem/RAS on Win2000/WinXP Pro
    By Youth_Jack in forum Symbian Networking & Messaging (Closed)
    Replies: 5
    Last Post: 2006-02-05, 17:48

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×