×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Jul 2009
    Posts
    3

    pys60 1.9.6 bt_discover (very strange)

    Hi guys,
    I am having a very strange problem when I use bt_discover(). Since my last post, I tried different things. I tried instantiating my variables as global and it seemed to work for a while. I was able to get bt_discover() to work for a while.
    I was trying to discover my N97 from the S60 emulator and vice versa. Since that was working, I tried to connect the two. Being my first attempt, it obviously was unsuccesful and python on both devices just hung. I restarted the two devices. Once I did that, bt_discover() works just fine when I try to discover any other device on either my phone or my emulator. But when I get the list of available devices,
    (1) when i choose to discover the emulator from my phone, it gives me error: 'no such file or directory'
    (2) when i choose to discover the phone from my emulator, python crashes with error:
    application closed
    PYTHON
    KERN-EXEC 3

    Can anyone please throw some light on what might be wrong here? Thanks in advance.

  2. #2
    Regular Contributor
    Join Date
    Apr 2009
    Posts
    65

    Re: pys60 1.9.6 bt_discover (very strange)

    This panic is raised when an unhandled exception occurs. Check if you handle the condition when your device fails to discover the emulator bluetooth device or viceversa.

    Exception handling - http://croozeus.com/blogs/?p=983
    --NirpSis

    http://sites.google.com/site/nirpsis/
    http://nirpsis.blogspot.com/

  3. #3
    Registered User
    Join Date
    Sep 2008
    Posts
    7

    Re: pys60 1.9.6 bt_discover (very strange)

    I'm having this same problem, as other seem to be on this other thread.

    I'm assuming that handling the exception is as simple as this code:
    import btsocket

    try:
    btsocket.bt_discover()
    except:
    print "Error"
    However, this doesn't help at all. The interpreter still exits, and Y-Tools tells me the error was KERN-EXEC: 3.

    Reproducing this problem is simple: run that script on one phone, and select another phone when the discovery menu is up.

    I'm having this problem on all my phones, both with PyS60 1.9.7 and the older 1.4.5. The phones models are E71, N95, N96-8GB.

    The only guess I have as to the source of the problem is this post stating that bt_discover will throw an exception if the selected device is not advertising any services. If this IS the problem, I see no way of catching the exception.

    Any thoughts on what is wrong here would be appreciated!
    Last edited by chris_uvic; 2009-10-19 at 01:13. Reason: Fix indentation

  4. #4
    Registered User
    Join Date
    Sep 2008
    Posts
    7

    Re: pys60 1.9.6 bt_discover (very strange)

    To follow up on my previous post here, the problem I'm seeing doesn't seem to relate to a phone not advertising services.

    When I'm using two phones, any attempt to use bt_discover() to query the second phone causes the first phone's Python interpreter to crash. This happens with the trivial code above, and it also happens with simple examples like the rfcomm_client.py from mobilenin.com.

    Things I've tried include:
    • PyS60 1.9.7
    • PyS60 1.4.5
    • PyS60 1.4.3 (I rolled that one back to see what would happen)
    • A reset of the phones using the *#7370# code
    • Deleting paired devices and pairing them again


    Now, bt_discover() DOES work if a desktop computer is selected from the bt_discover() pop-up menu. It seems to only be when another Nokia phone is selected from that bt_discover() pop-up menu that the crash occurs.

    If anyone has any suggestions as to what the problem might be, I'd love to hear them. I'm completely at a loss for what could be the problem here.

    Thanks!

Similar Threads

  1. pys60 1.9.6 bt_discover problem
    By sreekant in forum Symbian
    Replies: 5
    Last Post: 2009-07-31, 05:17
  2. btsocket problem pys60 1.9.6
    By finnsmama in forum Symbian
    Replies: 2
    Last Post: 2009-07-20, 19:48
  3. How to setup pys60 1.9.6 run with 5th Emulator?
    By nakhoncman in forum Symbian
    Replies: 2
    Last Post: 2009-07-16, 17:42
  4. New to Python for S60 (PyS60)? Read this first!
    By croozeus in forum Nokia N9
    Replies: 2
    Last Post: 2008-10-17, 19:23
  5. Replies: 4
    Last Post: 2008-08-12, 10:38

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×