×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    Jul 2009
    Posts
    3

    Carbide 2.0.4 and Qt Views won't work

    Hello,

    I've been struggling to get Qt Views working in Carbide 2.0.4 (Build v200905221036_65), and so far without success. The failing views are:
    - Qt C++ Property Editor
    - Qt C++ Widget Box
    Curiosly enough, the QtC++ Action and QtC++ signal (amongst other) do not yield any errors.

    They don't work in 'clean vanilla' setup (i.e. without 5.0 and/or Qt Tower SDKs installed), and problems remain the same after installing the SDKs and needed components.

    I am however able to write Qt projects and compile them (at least for emulator), that is without the aforementioned views (which need to be closed due to annoying error reports).

    ----- Here's what the problems look like:
    Open Carbide++ -> enable the aforementioned views, if not readily visible, from the Windows -> Show View ... menu.

    - Qt C++ Property Editor: "Problem Occured" popup is produced, yielding a java.lang.IndexOutOfBoundsException. Popup comes everytime I click any frame in the carbide.

    - Qt C++ Widget Box: No popup is produced, but the View tab shows a text: "Could not create the view: Index: 2, Size: 0" and a Details button.

    Looking at the Error Log tab, it reports this kind of problems:

    1. Unable to create view ID com.trolltech.qtcppdesigner.views.widgetboxview: Index: 2, Size: 0
    java.lang.IndexOutOfBoundsException: Index: 2, Size: 0
    at java.util.ArrayList.RangeCheck(Unknown Source)
    at java.util.ArrayList.get(Unknown Source)
    at com.trolltech.qtcppdesigner.views.embedded.WidgetBoxW.setBoxEnabled(WidgetBoxW.java:101)
    at com.trolltech.qtcppdesigner.views.WidgetBoxView.createPartControl(WidgetBoxView.java:53)
    at org.eclipse.ui.internal.ViewReference.createPartHelper(ViewReference.java:371)

    2.
    org.eclipse.swt.SWTException: Class ID not found in registry
    at org.eclipse.swt.ole.win32.OLE.error(OLE.java:317)
    at org.eclipse.swt.ole.win32.OLE.error(OLE.java:283)
    at org.eclipse.swt.ole.win32.OleControlSite.<init>(OleControlSite.java:96)
    at com.trolltech.qtcppdesigner.views.embedded.PropertyEditorW.<init>(PropertyEditorW.java:35)
    at com.trolltech.qtcppdesigner.views.PropertyEditorView.createPartControl(PropertyEditorView.java:49)
    at org.eclipse.ui.internal.ViewReference.createPartHelper(ViewReference.java:371)

    3. etc. similar messages many times.

    ----- /end how problem looks like

    I wonder what wrong am I doing with the Carbide... Normal Symbian projects work just fine with the installation. I reinstalled already everything once, without success. As far as I'm aware, I've tried to comply with all installation instructions.

    Any suggestions where to look at? Am I missing some DLLs?

    Deepest bows for help,
    -j

  2. #2
    Super Contributor
    Join Date
    Oct 2008
    Location
    INDIA
    Posts
    2,326

    Lightbulb Re: Carbide 2.0.4 and Qt Views won't work

    Download the latest version of carbide from tools and SDKs in the wiki home page..

    Also download Qt creater latest version then you will not struggle...
    ok.

  3. #3
    Registered User
    Join Date
    Aug 2008
    Posts
    3

    Re: Carbide 2.0.4 and Qt Views won't work

    I have exactly the same problem. I've installed all the lastest available sdks, tools etc to no avail.

    Did you the original poster resolve this issue?

    Please help...

    Regards,

    Mark

  4. #4
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Carbide 2.0.4 and Qt Views won't work

    just make sure you have latest version JRE installed .

  5. #5
    Registered User
    Join Date
    Jul 2010
    Posts
    20

    Re: Carbide 2.0.4 and Qt Views won't work

    Up In The Air

    Same hare, any solution? My configuration:
    qt-symbian-opensource-4.6.3.exe
    qt-sdk-win-opensource-2010.04.exe
    S60_5th_Edition_SDK_v1_0_en.zip
    ActivePerl-5.6.1.635-MSWin32-x86.msi
    ADT_v1.4.exe
    Carbide.c++.2.3

  6. #6
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Carbide 2.0.4 and Qt Views won't work

    try running this
    Code:
    C:\Symbian\Tools\ADT_1.4\Carbide.c++\configuration\qt\register_plugins.bat

  7. #7
    Registered User
    Join Date
    Jul 2010
    Posts
    20

    Re: Carbide 2.0.4 and Qt Views won't work

    It's working, thx.

Similar Threads

  1. Qt for Symbian development resources
    By liuxg in forum [Archived] Qt General ( Qt技术)
    Replies: 55
    Last Post: 2011-01-26, 04:06
  2. Unable to edit QT pro files in carbide
    By suresh.venkata in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 2
    Last Post: 2010-03-06, 11:59
  3. Q&A posted from Carbide webinar
    By Mike Trujillo in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 0
    Last Post: 2009-01-12, 23:01

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×