×

Discussion Board

Results 1 to 10 of 10
  1. #1
    Registered User
    Join Date
    Aug 2009
    Posts
    37

    Why don't S60 emulator loading?

    Hi, all
    Why don't S60 emulator loading?
    I use S60 5th SDK, and built all S60CppExamples.
    The emulator is terminated, or isn't loading for a long time.
    Why?
    Save me, please...

    Regards

  2. #2
    Super Contributor
    Join Date
    Oct 2007
    Location
    જુનાગઢ - India
    Posts
    3,034

    Re: Why don't S60 emulator loading?

    What other things you installed??? Are you vista user?

  3. #3
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,533

    Re: Why don't S60 emulator loading?

    Quote Originally Posted by K.John View Post
    Hi, all
    Why don't S60 emulator loading?
    I use S60 5th SDK, and built all S60CppExamples.
    The emulator is terminated, or isn't loading for a long time.
    Why?
    Save me, please...

    Regards
    Was the emulator working earlier? Any other SDK emulators work? Details always help to understand problem better.

  4. #4
    Registered User
    Join Date
    Aug 2009
    Posts
    37

    Re: Why don't S60 emulator loading?

    Quote Originally Posted by Symbian_Neil View Post
    Was the emulator working earlier? Any other SDK emulators work? Details always help to understand problem better.
    Hi,
    I installed nothing, but only installed S60 5th SDK and Carbide.c++ 2.0.
    I use Windows XP SP 2.
    What's the reason?

    Regards, John

  5. #5
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,672

    Re: Why don't S60 emulator loading?


  6. #6
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,533

    Re: Why don't S60 emulator loading?

    Sometimes some exotic (As once put by Wizard himself ) sound drivers do create such scenarios. Disabling them has helped quite a few.

    Besides that, epocwind.out is a good place to see whats going on.

  7. #7
    Registered User
    Join Date
    Aug 2009
    Posts
    37

    Re: Why don't S60 emulator loading?

    Quote Originally Posted by wizard_hu_ View Post
    Hi,
    The file is very complex and I cannot understand that.
    Give me advice.
    Regards.


    <<<<< epocwind.out >>>>>>>>>

    PlatSecEnforcement OFF
    PlatSecDiagnostics ON
    PlatSecProcessIsolation ON
    PlatSecEnforceSysBin ON
    PlatSecDisabledCaps NONE
    0.000 Thread 00c67468 created @ 0xc67468 - Win32 Thread ID 0x123c
    0.000 Thread EKern.exe::Supervisor created @ 0xd61c58 - Win32 Thread ID 0x1c0
    0.000 Thread EKern.exe:fcThread0 created @ 0xd628bc - Win32 Thread ID 0x9a4
    0.000 Thread EKern.exe:fcThread1 created @ 0xd62cec - Win32 Thread ID 0x12a4
    0.000 Thread EKern.exe::TimerThread created @ 0xd633dc - Win32 Thread ID 0x650
    0.000 Assertion failed: Interrupts must be enabled
    Function: Kern::Alloc
    0.005 Assertion failed: Interrupts must be enabled
    Function: Kern::HalFunction(TInt, TInt, TAny*, TAny*)
    0.010 Assertion failed: Interrupts must be enabled
    Function: Kern::Alloc
    0.020 Assertion failed: Interrupts must be enabled
    Function: Kern::HalFunction(TInt, TInt, TAny*, TAny*)
    0.025 Assertion failed: Interrupts must be enabled
    Function: Kern::HalFunction(TInt, TInt, TAny*, TAny*)
    0.030 Assertion failed: Interrupts must be enabled
    Function: Kern::Alloc
    0.035 Assertion failed: Interrupts must be enabled
    Function: Kern::Alloc
    0.040 Assertion failed: Interrupts must be enabled
    Function: Kern::Alloc
    0.045 Assertion failed: Interrupts must be enabled
    Function: Kern::AddHalEntry(TInt aId, THalFunc aFunc, TAny* aPtr, TInt aDeviceNumber)
    0.110 Assertion failed: Interrupts must be enabled
    Function: Kern::AddHalEntry(TInt aId, THalFunc aFunc, TAny* aPtr, TInt aDeviceNumber)
    3.040 Thread EKern.exe::FlashThread created @ 0xd72130 - Win32 Thread ID 0x1074
    3.080 Thread EKern.exe::MultiMediaCard0 created @ 0xd732cc - Win32 Thread ID 0x17d0
    3.125 Thread EKern.exe::NandThread created @ 0xd7e3b4 - Win32 Thread ID 0xb04
    3.150 Thread EFile.exe::Main created @ 0xd7f180 - Win32 Thread ID 0xd30
    3.150 Assertion failed: Interrupts must be enabled
    Function: DBase:perator new(TUint aSize)
    3.155 Thread EFile.exe::Local-00d81208 created @ 0xd814c8 - Win32 Thread ID 0x15d0
    3.155 Thread EFile.exe::LoaderThread created @ 0xd83158 - Win32 Thread ID 0xc40
    3.155 Thread EFile.exe::StartupThread created @ 0xd83774 - Win32 Thread ID 0x1098
    3.285 Thread E32STRT.EXE::Main created @ 0xd890ec - Win32 Thread ID 0x15d8
    3.290 Thread EFile.exe::Local-00d8922c created @ 0xd894ec - Win32 Thread ID 0x12a0
    3.290 Thread EFile.exe::Local-00d897e0 created @ 0xd89aa0 - Win32 Thread ID 0x172c
    3.290 Thread EFile.exe::Local-00d89d9c created @ 0xd8a05c - Win32 Thread ID 0x16a0
    3.300 Thread EFile.exe::InitCompleteThread created @ 0xd8c32c - Win32 Thread ID 0x11d4
    3.300 Assertion failed: Interrupts must be enabled
    Function: NKern::WaitForAnyRequest
    3.435 Thread domainSrv.exe::Main created @ 0xd8cc2c - Win32 Thread ID 0xa50
    3.870 Assertion failed: Do not call in ISR context
    Function: Kern::HalFunction(TInt, TInt, TAny*, TAny*)
    3.870 Assertion failed: Do not call in ISR context
    Function: NKern::LockSystem
    3.870 Assertion failed: Do not call in ISR context

    ........ ........... ............

    too long....

  8. #8
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,533

    Re: Why don't S60 emulator loading?

    Quote Originally Posted by K.John View Post
    Hi,
    The file is very complex and I cannot understand that.
    Give me advice.
    Regards.
    Instead of first parts, the last pasts is what would be of interest if you are interested in what must have gone wrong.

  9. #9
    Registered User
    Join Date
    Aug 2009
    Posts
    37

    Re: Why don't S60 emulator loading?

    Quote Originally Posted by Symbian_Neil View Post
    Instead of first parts, the last pasts is what would be of interest if you are interested in what must have gone wrong.
    Hi,
    Last part is followng.



    Function: NKern::LockSystem
    78.775 CTactileClickPlugin::OtherEvent - Begin
    78.775 CTactileClickPlugin::OtherEvent - End
    78.775 Thread akncapserver::akncapserver Panic ALLOC: 2d0223c8
    0
    78.775 Assertion failed: Interrupts must be enabled
    Function: Kern::HalFunction(TInt, TInt, TAny*, TAny*)
    78.825 Assertion failed: Interrupts must be enabled
    Function: Kern::Alloc
    78.830 Assertion failed: Interrupts must be enabled
    Function: Kern::Alloc
    78.840 Thread eiksrvs.exe::Main created @ 0xde583c - Win32 Thread ID 0x15b8
    78.840 Assertion failed: Interrupts must be enabled
    Function: Kern::MutexSignal
    78.845 CTactileClickPlugin::OtherEvent - Begin
    78.845 CTactileClickPlugin::OtherEvent - End
    78.845 FontProvider: Category=1, TextPane Height=8; mapped request=6; asked typeface=Series 60 Sans; given typeface=Series 60 Sans, actual range=7(a,d,exa,exd=5 1 1 0)
    78.845 Assertion failed: Interrupts must be enabled
    Function: NKern::LockSystem
    78.860 FontProvider: Category=1, TextPane Height=29; mapped request=26; asked typeface=Series 60 Sans; given typeface=Series 60 Sans, actual range=29(a,d,exa,exd=20 6 4 -1)
    78.865 Assertion failed: Interrupts must be enabled
    Function: NKern::LockSystem
    78.865 Assertion failed: Interrupts must be enabled
    Function: NKern::LockSystem
    78.870 Assertion failed: Interrupts must be enabled
    Function: NKern::LockSystem
    78.875 CTactileClickPlugin::OtherEvent - Begin
    78.875 CTactileClickPlugin::OtherEvent - End
    78.875 Thread eiksrvs.exe::EikAppUiServerThread Panic KERN-EXEC 3
    78.875 CTactileClickPlugin::OtherEvent - Begin
    78.875 CTactileClickPlugin::OtherEvent - End
    78.875 CTactileClickPlugin::OtherEvent - Begin
    78.875 CTactileClickPlugin::OtherEvent - End
    78.880 CTactileClickPlugin::OtherEvent - Begin
    78.880 CTactileClickPlugin::OtherEvent - End
    78.880 CTactileClickPlugin::OtherEvent - Begin
    78.880 CTactileClickPlugin::OtherEvent - End
    78.880 Thread akncapserver::akncapserver Panic ALLOC: 2b0223c8
    0
    79.175 RAknUiServer::ConnectAknServer() end
    79.175 CTactileClickPlugin::OtherEvent - Begin
    79.175 CTactileClickPlugin::OtherEvent - End
    79.175 Thread startup.exe::startup Killed -1
    79.285 RAknUiServer::ConnectAknServer() end
    79.285 CTactileClickPlugin::OtherEvent - Begin
    79.285 CTactileClickPlugin::OtherEvent - End
    79.285 Thread ailaunch.exe::ailaunch Killed -1
    79.380 RAknUiServer::ConnectAknServer() end
    79.380 [STRT][S]: [ERROR: -1]: CStrtExtensionPluginContainer::RunL
    79.380 [STRT][S]: [TIMESTAMP] (14:32:06.375000 us) End execute plugin (obj = 0x0ac41ab0)
    79.380 [STRT][S]: [INFO]: CStrtExtensionPluginContainer: completing request with -1
    79.380 [STRT][S]: [ERROR: -1]: CStrtStartList::RunL
    79.380 [STRT][S]: [ERROR: -1]: CStrtResourceStartList::HandleErrorL
    79.380 [STRT][S]: [ERROR: -1]: CStrtStartList::HandleErrorL
    79.380 [STRT][S]: [TIMESTAMP] (14:32:06.375000 us) End start list (obj = 0x0ac40804)
    79.380 [STRT][S]: [INFO]: Number of startup operations = 0
    79.385 CSharedRepository:oCommitChangesL - Failed to delete file. Error = -1
    79.385 [STRT][S]: [INFO]: Adaptation command id = 112
    79.385 [STRT][S]: [TIMESTAMP] (14:32:06.380000 us) Begin adaptation command 112
    79.395 [STRT][S]: [INFO]: Response to command 112, length: 4
    79.395 [STRT][S]: [TIMESTAMP] (14:32:06.390625 us) End adaptation command 112
    79.395 [STRT][S]: [INFO]: Adaptation command response error code = 0
    79.395 [STRT][S]: Task list 0x0ac40640 finished
    79.395 [STRT][S]: Task list 0x0ac40640, status 0
    79.395 [STRT][S]: [INFO]: Completing state machine client request with 0
    79.395 [STRT][S]: SHUTTING DOWN THE SYSTEM
    79.395 [STRT][S]: [INFO]: Active scheduler stopped - cleaning up
    79.395 [STRT][S]: Unloading plugin library 0x1020506c
    79.395 [STRT][S]: Unloading plugin library 0x10205069
    79.395 CDiskSpaceReservationPlugIn::~CDiskSpaceReservationPlugIn
    79.395 RDosSharedData::Close(), calling RequestFreeDiskSpaceCancel()
    79.395 RDosSharedData::RequestFreeDiskSpaceCancel(), calling SendReceive
    79.395 [DOSSERVER] CDosSession::ServiceL()
    79.395 [DOSSERVER] CDosSession:ispatchMessageL()
    79.395 [DOSSERVER] dosService created, continuing...
    79.395 [DOSSERVER] Calling ExecuteMessageL...
    79.395 [DOSSERVER] CDosSharedDataBase::ExecuteMessageL(...)
    79.395 CDosSharedDataBase::ExecuteMessageL() case ERequestFreeDiskSpaceCancel iFreeDiskSpaceRequest = 143360
    79.395 [DOSSERVER] CDosSharedDataBase::RequestFreeDiskSpaceCancel
    79.395 CDosServer::CurrentFreeDiskSpaceRequest()
    79.395 CDosServer::SetCurrentFreeDiskSpaceRequest()
    79.395 [DOSSERVER] CDosSharedDataBase::SetReserveFileSize
    79.400 SharedData: SetReserveFileSize() start
    79.400 SharedData: Free disk space: 670072832
    79.400 SharedData: Reserve file size: 262144
    79.400 SharedData: SetReserveFileSize() loop
    79.400 SharedData: Free disk space: 670072832
    79.400 SharedData: Expected reserve file size: 262144
    79.400 SharedData: Reserve file size: 262144
    79.400 SharedData: Free disk space: 670072832
    79.400 SharedData: Expected reserve file size: 262144
    79.400 SharedData: Reserve file size: 262144
    79.400 [DOSSERVER] CDosSharedDataBase::SetReserveFileSize - return
    79.400 [DOSSERVER] CDosSharedDataBase::RequestFreeDiskSpaceCancel - return
    79.400 RDosSharedData::Close(), calling CloseSubSession(EDosCloseSubSession)
    79.400 [DOSSERVER] CDosSession::ServiceL()
    79.400 [DOSSERVER] CDosSession:ispatchMessageL()
    79.400 [DOSSERVER] EDosCloseSubSession
    79.400 [DOSSERVER] CDosSession::CloseSubSession()
    79.400 [DOSSERVER] CDosSharedDataBase::~CDosSharedDataBase()
    79.400 [DOSSERVER] RDosServer::Close()
    79.400 CDosSession::~CDosSession()
    79.400 [DOSSERVER] Deleting services...
    79.400 [DOSSERVER] iServices : 11208332
    79.400 [DOSSERVER] iServices count: 0
    79.400 [DOSSERVER] Callback dropsession
    79.400 [DOSSERVER] ** CDosServer - Drop session, count: 0
    79.400 [DOSSERVER] iServiceCon - remove callback
    79.400 [DOSSERVER] iServiceCon : 11208264
    79.400 [DOSSERVER] iServiceCon count: 0
    79.400 CDosSession::~CDosSession() - end
    79.400 CDiskSpaceReservationPlugIn::~CDiskSpaceReservationPlugIn finished
    79.400 [STRT][S]: [INFO]: Active scheduler stopped - switching off HAL
    79.400 [STRT][S]: [TIMESTAMP] (14:32:06.395625 us) End S60 shutdown
    79.405 Assertion failed: Interrupts must be enabled
    Function: NKern::LockSystem
    86.725 Assertion failed: Interrupts must be enabled
    Function: Kern::ObjectFromHandle(DThread* aThread, TInt aHandle, TInt aType)
    123.170 Assertion failed: Interrupts must be enabled
    Function: Kern::MutexSignal
    123.235 Assertion failed: Interrupts must be enabled
    Function: Kern::MutexSignal
    394.425 Assertion failed: Interrupts must be enabled
    Function: NKern::LockSystem
    610.425 Assertion failed: Interrupts must be enabled
    Function: NKern::LockSystem
    829.435 Assertion failed: Interrupts must be enabled
    Function: Kern::AddEvent
    850.435 Assertion failed: Interrupts must be enabled
    Function: NKern::WaitForAnyRequest
    895.430 Assertion failed: Interrupts must be enabled
    Function: NKern::LockSystem
    1282.425 Assertion failed: Interrupts must be enabled
    Function: Kern::MutexWait
    1345.425 Assertion failed: Interrupts must be enabled
    Function: Kern::MutexSignal
    1570.425 Assertion failed: Interrupts must be enabled
    Function: NKern::ThreadRequestSignal(NThread*,NFastMutex*)
    1666.425 Assertion failed: Interrupts must be enabled
    Function: DThread::AddCleanup
    1699.425 Assertion failed: Interrupts must be enabled
    Function: NKern::LockSystem
    1723.425 Assertion failed: Interrupts must be enabled
    Function: NKern::LockSystem
    1768.425 Assertion failed: Interrupts must be enabled
    Function: Kern::AddEvent
    1840.430 Assertion failed: Interrupts must be enabled
    Function: TTickLink::OneShot
    1876.425 Assertion failed: Interrupts must be enabled
    Function: NKern::WaitForAnyRequest
    2203.425 Assertion failed: Interrupts must be enabled
    Function: Kern::ObjectFromHandle(DThread* aThread, TInt aHandle, TInt aType)
    2461.425 Assertion failed: Interrupts must be enabled
    Function: NKern::LockSystem
    2494.425 Assertion failed: Interrupts must be enabled
    Function: NKern::LockSystem
    2767.430 Assertion failed: Interrupts must be enabled
    Function: NKern::LockSystem
    3010.425 Assertion failed: Interrupts must be enabled
    Function: Kern::ObjectFromHandle(DThread* aThread, TInt aHandle, TInt aType)
    3052.425 Assertion failed: Interrupts must be enabled
    Function: NKern::LockSystem
    3643.425 Assertion failed: Interrupts must be enabled
    Function: Kern::MutexWait
    3856.040 Assertion failed: Interrupts must be enabled
    Function: NKern::LockSystem


    Regards!!!!!!

  10. #10
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,533

    Re: Why don't S60 emulator loading?

    http://discussion.forum.nokia.com/fo...d.php?t=176490
    Ok, so the emulator starts, just that its slow!!

Similar Threads

  1. S60 Browser 7.1
    By Nokia Ron in forum Symbian
    Replies: 8
    Last Post: 2010-07-12, 19:18
  2. Python for S60 1.9.6 released
    By tvijayan in forum Symbian
    Replies: 27
    Last Post: 2009-07-19, 15:52
  3. Python for S60 1.9.2 released
    By tvijayan in forum Symbian
    Replies: 26
    Last Post: 2009-03-11, 09:28

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×