×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Dec 2008
    Posts
    10

    Problem with PAMP, MWS and mod_php

    Hi there!
    I've installed MWS yesterday, and I've noticed that it has no PHP built-in. So I've started to search for a WS what has the PHP module, and I found PAMP. So I've downloaded the latest PAMP, and installed it after uninstalling WMS and its parts (I know that I could keep it, but my phone has low built-in memory [30 MB, after formatting it is 27,5 MB, and I need the space for Python and Maps]). I've installed it, restarted my phone, and started the server... What am I saying, I've tried to start it... because MySQL starts without problem, but Apache won't start... So I've checked out the stderr log, and got this:

    Code:
    E:\\sys\\bin\\httpds22.exe: Syntax error on line 288 of /data/web server/conf/httpd.conf: Cannot load httpd22-mod_php.so into server: dlopen: Load failed
    What I've got from this message,that the PHP mod failed to load, and this caused an error so huge that Apache won't start...



    More information:
    Phone model: Nokia 6650d-1c
    FW version: 04.18 (I don't know how, approx. a month ago I've tried to update my phone and it downloaded this new FW... but after trying to "refurbish" it with NSU, it wrote that I have newer FW what the server have...)
    OS version: Symbian v9.3 S60v3 FP2
    Apps installed:
    - X-Plore 1.33 trial
    - MWS (before installing PAMP)
    - PAMP (after uninstalling MWS)
    - Python 1.4.5
    - pyMegaPyModulePack

    And by the way I've tried to get the PHP module working under MWS (unpacked the PAMP installer and created a selfsigned package from the PHP mod stuff... it installed without problem and I've added it to the HTTPD.CONF :
    Code:
    LoadModule php-5_2_2 httpd22-mod_php.so
    After it I've tried to start the server in both local and connected mode... it failed to start because of the PHP module...)


    Is there anything to do? I wanna test my site under phone browser too!

  2. #2
    Nokia Developer Expert
    Join Date
    Mar 2003
    Posts
    457

    Re: Problem with PAMP, MWS and mod_php

    Quote Originally Posted by fonix232 View Post
    ...
    And by the way I've tried to get the PHP module working under MWS (unpacked the PAMP installer and created a selfsigned package from the PHP mod stuff... it installed without problem and I've added it to the HTTPD.CONF :
    Code:
    LoadModule php-5_2_2 httpd22-mod_php.so
    After it I've tried to start the server in both local and connected mode... it failed to start because of the PHP module...)
    Have you tried install MWS and then just install PAMP on top it? The latest version of PAMP is fully compatible with MWS and there is no need to extract any files and/or build custom installation packages.

    Br,
    Johan

  3. #3
    Registered User
    Join Date
    Jan 2009
    Posts
    9

    Re: Problem with PAMP, MWS and mod_php

    Hi, fonix232

    If you want to run php, then it is good using FineWS 2.3.
    They said that Joomla can be run on their web server (FineWS).

    you can see it now, http://finemobileweb.net.

    It has also internet gateway service, such as http://mymobilesite.net.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×