×

Discussion Board

Results 1 to 11 of 11
  1. #1
    Registered User
    Join Date
    Feb 2008
    Posts
    37

    Signed Application not working

    Hi

    Want to ask you a question?

    JSR 234 isn't supported by Nokia N73 (camera API). So does that mean a j2me camera application can't be developed for the Nokia N73.


    Moreover

    I 'm facing a strange problem that my unsigned application runs fine on Nokia N73 but after signing and running it , It stops working. On Nokia E90 the same signed application works properly.

  2. #2
    Nokia Developer Champion
    Join Date
    Feb 2009
    Location
    Noida, India
    Posts
    3,085

    Re: Signed Application not working

    Fotr 1st part refer to FN wiki:
    http://wiki.forum.nokia.com/index.ph...ots_in_Java_ME

    For moreover:

    What do you mean by after signing and running it , It stops working?

    thanks,
    ~Amitabh

  3. #3
    Registered User
    Join Date
    Feb 2008
    Posts
    37

    Re: Signed Application not working

    Hi

    Amitabh


    Thanks for replying

    I 've soloved the problem regarding camera application.
    For another j2me application it access the network properly when not signed but throws "403 forbidden" error whenever executed after signing.

  4. #4
    Nokia Developer Champion
    Join Date
    Feb 2009
    Location
    Noida, India
    Posts
    3,085

    Re: Signed Application not working

    Which certificate did you use to sign the app ? is it available on your target device ?

    thanks,
    ~Amitabh

  5. #5
    Registered User
    Join Date
    Feb 2008
    Posts
    37

    Re: Signed Application not working

    Hi

    It's versign class 3 Code Signing Certficate that is available on the phone. I 've manually installed the certificate.

  6. #6
    Nokia Developer Champion
    Join Date
    Feb 2009
    Location
    Noida, India
    Posts
    3,085

    Re: Signed Application not working

    Try on any other phone on which the public versign class 3 Code Signing Certficate comes already installed with the firmware and check, manually installed certificate often create problems.

    thanks,
    ~Amitabh

  7. #7
    Registered User
    Join Date
    Mar 2003
    Posts
    4,105
    With 403 your refer to an HTTP error, correct? You use HttpConnection class, correct? Why should a HTTP error be related to MIDP code-signing? Perhaps because you (or your provider) looks at the User-Agent Header …
    Quote Originally Posted by success_anil View Post
    I 've manually installed the certificate.
    How do you enable it for code-signing then?

  8. #8
    Registered User
    Join Date
    Feb 2008
    Posts
    37

    Re: Signed Application not working

    Quote Originally Posted by im2amit View Post
    Try on any other phone on which the public versign class 3 Code Signing Certficate comes already installed with the firmware and check, manually installed certificate often create problems.

    thanks,
    ~Amitabh
    Ok..

    That's what i did. I installed the same app on Nokia E90 and it worked fine

  9. #9
    Nokia Developer Champion
    Join Date
    Feb 2009
    Location
    Noida, India
    Posts
    3,085

    Re: Signed Application not working

    The problem looks to be beacuse of different UserAgent headers on both of the devices...and your Server.

    thanks,
    ~Amitabh

  10. #10
    Registered User
    Join Date
    Feb 2008
    Posts
    37

    Re: Signed Application not working

    Quote Originally Posted by im2amit View Post
    The problem looks to be beacuse of different UserAgent headers on both of the devices...and your Server.

    thanks,
    ~Amitabh
    Thanks Amitabh

    I 've solved the problem by changing user agent

  11. #11
    Nokia Developer Champion
    Join Date
    Feb 2009
    Location
    Noida, India
    Posts
    3,085

    Re: Signed Application not working

    Thats good finally you got success and we identified the right issue.

    thanks,
    ~Amitabh

Similar Threads

  1. Do Symbian rejects the Express Signing request on any Business Development ground?
    By arpit2agrawal in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 23
    Last Post: 2009-02-19, 10:46
  2. Getting annoying messages even the application is signed.
    By manojkumar.m in forum Mobile Java General
    Replies: 3
    Last Post: 2008-06-11, 12:17
  3. My application is not working when I signed using Thwate.
    By manojkumar.m in forum Mobile Java General
    Replies: 6
    Last Post: 2008-05-31, 22:00
  4. Problems with a signed application
    By Alfury in forum Mobile Java Networking & Messaging & Security
    Replies: 7
    Last Post: 2008-03-27, 05:15
  5. Replies: 0
    Last Post: 2006-10-16, 17:31

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×