×

Discussion Board

Results 1 to 9 of 9
  1. #1
    Registered User
    Join Date
    Sep 2009
    Posts
    3

    unable to install python runtime on N78: "component built in"

    hi guys,

    I'm trying to install Python s60 on my Nokia n78 which has a s60 3rd fp2 ...
    unfortunately I get the "unable to install, component is built-in"

    Error pops up after installing message for: Symbian OS PIPES upgrade, v1.0.3.

    my firmware is 12.046, language set 001.

    I read various forum posts but I still didn't find a solution..
    this is a branded phone and this is the latest firmware available..

    What should I do?

    Thanks,

    Fabio Varesano

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,165

    Re: unable to install python runtime on N78: "component built in"

    the error means that packet with same UID is already present in the device, and it is in the ROM, thus it can not be replaced.

  3. #3
    Registered User
    Join Date
    Sep 2009
    Posts
    3

    Re: unable to install python runtime on N78: "component built in"

    thanks for your reply. But how can I install Python on my Phone with this issue? Are there workarounds?

  4. #4
    Registered User
    Join Date
    Sep 2006
    Posts
    6

    Re: unable to install python runtime on N78: "component built in"

    When you run the python installer, does it say "component built in" right after you press ok to "pips"? if it does, it just means that pips is already installed on your phone internally and you cannot reinstall it. It is not python that is built in. I am using n78 and have the same problem. The solution is however not known to me as i am trying to figure this out too. lol

  5. #5
    Registered User
    Join Date
    Sep 2009
    Posts
    3

    Re: unable to install python runtime on N78: "component built in"

    Yes, the error appears just after accepting the pips component. So it's probably already installed. Unfortunately I wasn't able to find a Python package without it.. It's probably possible to break the python package remove pips and then recreate a new package but I never understood how.

    Actually, after that nobody helped out on this forum and I googled everything for some days, I give up.

    Please help me if you got success with this.

  6. #6
    Registered User
    Join Date
    Dec 2009
    Posts
    2

    Re: unable to install python runtime on N78: "component built in"

    I have got the same problem with my N78.
    When i try to install python the error pops up right after pipes.Component already installed.....
    Well, if i try to install Python 2.00 the installation works fie but the Scriptshell didnt see it.
    It tells me : Please check if the following components are installed: Python runtime, Pips library.
    I´m trying to install python for 2 months so please help.

    @fax8 theres a python version outside without pips its for 5th but it will work on 3rd too, but the scriptshell will not see it.
    Last edited by droxkne; 2009-12-29 at 09:52.

  7. #7
    Super Contributor
    Join Date
    Nov 2007
    Location
    Sertaozinho/Brazil
    Posts
    768

    Re: unable to install python runtime on N78: "component built in"

    I have users that have problems with Python installer (N79, E61i) and they are using an alternative installer called Python_1.9.6_fixed.sis. Wanna try ?

  8. #8
    Registered User
    Join Date
    Dec 2009
    Posts
    2

    Re: unable to install python runtime on N78: "component built in"

    Quote Originally Posted by marcelobarrosalmeida View Post
    I have users that have problems with Python installer (N79, E61i) and they are using an alternative installer called Python_1.9.6_fixed.sis. Wanna try ?
    Thx, but it has the same problem: Component built in .

    Is there a problem with my N78 or is python not ready for it?

    EDIT: Finally Python is running on my N78.It´s only the 1.45 version but its running.I installed the version from one topic where someone extracted the version from the mobile web server(I forgot to save the link). BTW: YAY
    Last edited by droxkne; 2009-12-31 at 12:26.

  9. #9
    Regular Contributor
    Join Date
    Dec 2008
    Location
    Seattle, US
    Posts
    145

    Re: unable to install python runtime on N78: "component built in"

    Quote Originally Posted by droxkne View Post
    I have got the same problem with my N78.
    When i try to install python the error pops up right after pipes.Component already installed.....
    Well, if i try to install Python 2.00 the installation works fie but the Scriptshell didnt see it.
    It tells me : Please check if the following components are installed: Python runtime, Pips library.
    I´m trying to install python for 2 months so please help.

    @fax8 theres a python version outside without pips its for 5th but it will work on 3rd too, but the scriptshell will not see it.
    I have the same problem. Python 2.0 runtime is installed correctly, but the script shell fails to see it. Can anybody please help here??? I'm also trying to install Python for a month or two now. I would have to write my apps in C++ if this can't be resolved .

Similar Threads

  1. Please help installing Python libraries on S60
    By ericroijen in forum Symbian
    Replies: 11
    Last Post: 2009-07-18, 10:43
  2. Problem with install Python SDK on PC
    By znakharenko in forum Symbian
    Replies: 9
    Last Post: 2008-08-14, 04:29
  3. Unable to install. Constrained by the certificate
    By anhquan in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 2
    Last Post: 2007-10-17, 10:29
  4. Replies: 1
    Last Post: 2007-04-16, 11:05
  5. Replies: 6
    Last Post: 2006-03-04, 01:04

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×