×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Regular Contributor
    Join Date
    Sep 2007
    Posts
    247

    CAknItemFinder not working for S60 5th Ed?

    Hi,

    I downloaded the Item finder API from the http://wiki.forum.nokia.com/index.php/SDK_API_Plug-in, and which is working absolutely fine with 3rd SDK. But when i tried the same with the S60 5th, it started giving me the problem as:
    Code:
    mwldsym2.exe: Undefined symbol: 'class CAknItemFinder * CAknItemFinder::NewL(int) (?NewL@CAknItemFinder@@SAPAV1@H@Z)'
    Obviousely, the plug in, I used, was for 3rd Ed. So My questions are:
    1. do we have any update plugin for 5th Ed? if yes please share the link to download the same.
    2. And if this API is depricated by any chance (which I feel shouldnt be the case ), please let me know what is its quivalent in 5th Ed?

    Regards,
    Jupitar

  2. #2
    Super Contributor
    Join Date
    Nov 2004
    Posts
    1,009

    Re: CAknItemFinder not working for S60 5th Ed?

    Below link has plug-in for 5th edition ItemFinder API

    http://wiki.forum.nokia.com/index.php/SDK_API_Plug-in
    Regards,
    Shafali

  3. #3
    Regular Contributor
    Join Date
    Sep 2007
    Posts
    247

    Re: CAknItemFinder not working for S60 5th Ed?

    Quote Originally Posted by shafalig82 View Post
    Below link has plug-in for 5th edition ItemFinder API

    http://wiki.forum.nokia.com/index.php/SDK_API_Plug-in
    hmmm, i used and referred the same link in my original post. but ignored the later part of the webpage, got it there only.

    Thnx shafalig82 for sending the link again

  4. #4
    Regular Contributor
    Join Date
    Sep 2007
    Posts
    247

    Re: CAknItemFinder not working for S60 5th Ed?

    i tried the plug in from "API Plug-in for the S60 5th Edition SDK for Symbian OS, for C++" section of http://wiki.forum.nokia.com/index.php/SDK_API_Plug-in. But It gave me no difference to my problem . Please help..

  5. #5
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    50

    Re: CAknItemFinder not working for S60 5th Ed?

    Hi

    Api is changed to CItemFinder from CAknItemFinder in the extension plug-in for 5th edition. Please refer to C:\S60\devices\S60_5th_Edition_SDK_v1.0\epoc32\include\itemfinder.h after installing the extension plugin.

  6. #6
    Registered User
    Join Date
    Feb 2010
    Posts
    5

    Re: CAknItemFinder not working for S60 5th Ed?

    Quote Originally Posted by jupitar View Post
    Hi,

    I downloaded the Item finder API from the http://wiki.forum.nokia.com/index.php/SDK_API_Plug-in, and which is working absolutely fine with 3rd SDK. But when i tried the same with the S60 5th, it started giving me the problem as:
    Code:
    mwldsym2.exe: Undefined symbol: 'class CAknItemFinder * CAknItemFinder::NewL(int) (?NewL@CAknItemFinder@@SAPAV1@H@Z)'
    Obviousely, the plug in, I used, was for 3rd Ed. So My questions are:
    1. do we have any update plugin for 5th Ed? if yes please share the link to download the same.
    2. And if this API is depricated by any chance (which I feel shouldnt be the case ), please let me know what is its quivalent in 5th Ed?

    Regards,
    Jupitar
    Hi Jupitar,

    How do you add the plug-in to your project. I am using carbide. C++ IDE. Please help me.
    Regards,
    krishnan.

  7. #7
    Registered User
    Join Date
    Feb 2010
    Posts
    39

    Re: CAknItemFinder not working for S60 5th Ed?

    Quote Originally Posted by krishnan.selvaraj View Post
    Hi Jupitar,

    How do you add the plug-in to your project. I am using carbide. C++ IDE. Please help me.
    For 5th edition you must hv got the .exe as plugin , install the exe and plugin would be installd in your SDK>

Similar Threads

  1. S60 5th ed. emulator installation
    By afsheen in forum Mobile Java Tools & SDKs
    Replies: 9
    Last Post: 2009-04-18, 08:33
  2. Replies: 13
    Last Post: 2009-04-17, 16:53
  3. [moved] Is ETEL supported by S60 5th ed?
    By Sergey_Burish in forum Symbian Networking & Messaging (Closed)
    Replies: 4
    Last Post: 2009-04-13, 08:31
  4. S40 3rd Ed FP2 (5300) Signing not working properly
    By pillar in forum Mobile Java General
    Replies: 8
    Last Post: 2007-05-16, 08:09
  5. Network connection not working on S60 2nd Ed FP2 emulator
    By jalakuri in forum Symbian Networking & Messaging (Closed)
    Replies: 7
    Last Post: 2007-05-08, 15:47

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •