Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Jun 2009

    [moved] Carbide shows grey code

    Hi everybody,
    I have a strange problem and I think I need some help. I have an application in s60 3rd Ed that uses Browser Control API and an HTTP Request. Suddenly it stopped working with a Panic ViewSrv 11 and since then my code appears in grey color. I tryed to go back to a previous version that worked fine and the same! code appears in grey color and when I try to run application on emulator it crashes with a Panic ViewSrv 11.
    I know Panic ViewSrv 11 occurs when an application has locked up for a number of seconds, but has no sense because happends even using a backup version of the application that worked fine
    When I try to run the app in a real device it works fine, so I think there is something wrong with Carbide (v2.0)
    I don´t know what`s happening. Any idea, please?
    Last edited by stevepatrick; 2009-09-25 at 08:52. Reason: More info added

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Oslo, Norway

    Re: Carbide shows grey code

    Note that Carbide.c++ does not always notice/care if you change the files 'outside' (including the restoration from some backup), thus you are probably still running the 'new' (bogus) code. Make sure that your project is properly re-built, use Clean on it, or as an extreme solution, remove its temporary files in epoc32\BUILD.

  3. #3
    Nokia Developer Expert
    Join Date
    Dec 2004
    Austin, TX

    Re: [moved] Carbide shows grey code

    Grey code indicates the indexer cannot resolve the symbol(s). Right click in the project and choose Index > Rebuild. When in doubt, do a reallyclean.

  4. #4
    Registered User
    Join Date
    Mar 2012

    Re: [moved] Carbide shows grey code

    I had same kind of problem and above methods were not working . I resolved it : through replacing your old .cproject file and mmp files with changed one.

Similar Threads

  1. Replies: 106
    Last Post: 2009-05-11, 05:53
  2. [moved] Carbide produces useless sis files
    By dhitchman in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 25
    Last Post: 2009-04-15, 19:09
  3. [moved] Problem Trk 3.0.9 in n80 with carbide 2
    By elsuicidas in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 0
    Last Post: 2009-02-10, 16:02
  4. Carbide v1.2 has trouble recognizing changes in code
    By codepatch in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2007-06-15, 20:08

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts