×

Discussion Board

Results 1 to 12 of 12
  1. #1
    Registered User
    Join Date
    Jan 2009
    Location
    ભારત->ગુજરાત->ભાવનગર
    Posts
    279

    Question installation problem

    i am trying to install the scratchbox, i am using ubuntu 8.10 .........i have downloaded the file with the help of this script:
    $ wget http://repository.maemo.org/unstable...all_5.0beta.sh http://repository.maemo.org/unstable...all_5.0beta.sh

    but i am not able to run this given script to make the scratchbox install..

    sudo ./maemo-scratchbox-install_5.0beta.sh –u USER

    plz help?
    let me know the steps to install scratchbox....
    Regards
    Viral Parmar

  2. #2
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: installation problem

    Have you modified script's attributes to allow it to execute? And generally speaking, post the error messages when something does not work, that's the only way one can get a clue what happens on your machine ...

    Here are the step by step instructions: http://maemo.org/development/sdks/ma..._installation/
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  3. #3
    Registered User
    Join Date
    Jan 2009
    Location
    ભારત->ગુજરાત->ભાવનગર
    Posts
    279

    Post Re: installation problem

    My OS terminal is unable to execute this "sudo ./maemo-scratchbox-install_5.0beta.sh –u viral
    " command
    i have also modified the attribute by using "chmod a+x scratchbox-maemo5.sh"

    Error:Command not found
    Regards
    Viral Parmar

  4. #4
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: installation problem

    Check your file paths, apparently the script file cannot be found at the specified location.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  5. #5
    Regular Contributor
    Join Date
    Mar 2009
    Posts
    430

    Re: installation problem

    Try to pass the absolute path to the executable. Maybe the relative path "./XXX" does not work together with sudo. Also if changing the exec bit does not work, try to open explicitely using the sh-interpreter: sudo sh myfile.sh

  6. #6
    Registered User
    Join Date
    Jan 2009
    Location
    ભારત->ગુજરાત->ભાવનગર
    Posts
    279

    Smile Re: installation problem

    thanks to all finally i have solved the problem.........


    first we have to run the script given below..

    echo 0 | sudo tee /proc/sys/vm/vdso_enabled to enable VSDO

    then after go for this

    sudo ./maemo-scratchbox-install_5.0beta.sh –u viral
    Regards
    Viral Parmar

  7. #7
    Registered User
    Join Date
    Jan 2009
    Location
    ભારત->ગુજરાત->ભાવનગર
    Posts
    279

    Smile Re: installation problem

    hii
    thanks for the previous help....

    actually after installation of the scratchbox....

    i have continued with $ sh maemo-sdk-install_5.0beta2.sh this script
    but i was facing error like you have to run this file "run_me_first.sh"

    i am totally unable to install and run the script ....

    thanks...
    Regards
    Viral Parmar

  8. #8
    Regular Contributor
    Join Date
    Mar 2009
    Posts
    430

    Re: installation problem

    What is the exact name of the missing file?

  9. #9
    Registered User
    Join Date
    Jun 2009
    Posts
    1

    Re: installation problem

    Quote Originally Posted by axeljaeger View Post
    What is the exact name of the missing file?
    I had the same problem with Ubuntu 9.10 64bit.
    Scratchbox installation doesn't succeed. It doesn't create new group etc.
    Error message says that user should run /scratchbox/run_me_first.sh but there is no such file. I searched the whole computer and there is no such file anywhere else either. The Ubuntu packages I looked don't have such file either.

    I managed to solve this by getting run_me_first.sh from internet (scratchbox.org IIRC, not at all sure if this is wise thing to do) and running it manually.

    There is definitely something wrong with the scratchbox installation script (or the installation guide) on some systems.

  10. #10
    Registered User
    Join Date
    Jan 2009
    Location
    ભારત->ગુજરાત->ભાવનગર
    Posts
    279

    Post Re: installation problem

    hi
    the same the thing is happening with me..........i am unable to run the script for sdk installation ....i was facing error like :

    Create new user as your admin name
    run the file run_me_first as this file is not available anywhere in scratchbox installation directory
    Regards
    Viral Parmar

  11. #11
    Super Contributor
    Join Date
    Oct 2009
    Posts
    4,326

    Re: installation problem

    Quote Originally Posted by mind_freak View Post
    first we have to run the script given below..

    echo 0 | sudo tee /proc/sys/vm/vdso_enabled to enable VSDO
    This command disables VDSO, alternatively you may disable it at boot by adding vdso=0 to the end of kernel lines at /boot/grub/menu.lst

  12. #12
    Registered User
    Join Date
    Nov 2009
    Posts
    10

    Re: installation problem

    Edit: nvm.
    Last edited by beaua; 2009-11-09 at 10:42.

Similar Threads

  1. Modules required :)
    By neil.young in forum Symbian
    Replies: 20
    Last Post: 2009-06-07, 11:35
  2. [moved] SIS file installation problem with 6630
    By mimimi in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 1
    Last Post: 2009-04-14, 12:49
  3. STLPort namespace issue
    By yickhong in forum Open C/C++
    Replies: 0
    Last Post: 2009-04-09, 08:54
  4. Installation problem for S60 3.0 SDK
    By harri_salminen in forum Symbian Tools & SDKs
    Replies: 4
    Last Post: 2007-11-14, 22:01
  5. Installation Problem on the Nokia 6600
    By ManishPatil in forum Symbian
    Replies: 1
    Last Post: 2005-02-02, 09:51

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×