×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Regular Contributor
    Join Date
    Apr 2009
    Posts
    442

    Build time Error: mwldsym2.exe: Undefined symbol:

    Hi

    I getting following error in Console Build(WinCW) Screen.

    Errors caused tool to abort.
    make[1]: *** [\Symbian\9.2\S60_3rd_FP1_2\EPOC32\RELEASE\WINSCW\UDEB\CodecPlayerDLL.dll] Error 1
    make: *** [TARGETCODECPLAYERDLL] Error 2
    make -j 4 -s -r -f "\Symbian\9.2\S60_3rd_FP1_2\EPOC32\BUILD\Symbian\Code\CODEC\OPEN_C\CodecPlayerDLL\DLLs\CODECPLAYERDLL\WINSCW\CODECPLAYERDLL.WINSCW" UDEB
    WARNING: Not attempting to create "\Symbian\9.2\S60_3rd_FP1_2\EPOC32\RELEASE\WINSCW\UDEB\CodecPlayerDLL.lib".
    When exports are frozen in "\Symbian\Code\CODEC\OPEN_C\CodecPlayerDLL\DLLs\CODECPLAYERDLL\GROUP\CODECPLAYERDLLWINS.def", regenerate Makefile.
    mwldsym2.exe: Undefined symbol: 'void CPlayerUIListener::ConstructL(void) (?ConstructL@CPlayerUIListener@@UAEXXZ)'
    mwldsym2.exe: referenced from 'const CPlayerUIListener::`vftable' (??_7CPlayerUIListener@@6B@~)' in CodecPlayerDLL.o

    I am try to build DLL Application and also included all header files and library.
    Where is I am missing something anybody have any idea?
    Please help me.

    Regards
    SymbianTH

  2. #2
    Regular Contributor
    Join Date
    Apr 2009
    Posts
    442

    Re: Build time Error: mwldsym2.exe: Undefined symbol:

    Hi

    Thanks I Solved this error. I Forgot myfunction()=0; in one function.

    SymbianTH

  3. #3
    Registered User
    Join Date
    Jun 2007
    Location
    Mumbai, India
    Posts
    1,998

    Re: Build time Error: mwldsym2.exe: Undefined symbol:

    It seems it cannot find definition for CPlayerUIListener

Similar Threads

  1. Problem in CAknTextQueryDialog
    By saaa_persistent in forum Symbian User Interface
    Replies: 5
    Last Post: 2009-07-30, 08:58
  2. How to capture long key press using CaptureLongKey() function??
    By rohanwaugh in forum Symbian User Interface
    Replies: 15
    Last Post: 2008-09-17, 10:27
  3. Linker error in Carbide C++
    By Tejaswini in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 3
    Last Post: 2007-01-30, 16:33
  4. Replies: 0
    Last Post: 2006-08-18, 10:17
  5. S80 Platform SDK and Visual Studio .NET Linking Error
    By jayantjain in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2005-10-07, 22:14

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×