×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Jun 2008
    Location
    Poland
    Posts
    60

    Problem moving intercepted messsage

    Hi,

    I'm intercepting messages using sockets. After analyzing sender number some of them are put in inbox, some in another folders (inbox's subfolder).
    If I save the message in subfolder, than I've a little problem:
    I select any message and choose from menu Move to folder option. Choose any folder. Nothing happens, the message will be still inside original folder.
    Option Move to folder is also available when message is open to read. But in that case works correctly.

    Unfortunetly it's not possible to create manually message in subfolder, so no
    idea if it's my fault or symbian issue.
    But I check another option: modified application so messages are sent to outbox
    folder. When our application moved message to outbox, then it's possible to
    move this message to inbox in both cases - when messages' list is visible and
    when message is opened.
    Message is sent to outbox the same way like to inbox's subfolder. So maybe it's
    symbian issue that messages from inbox's subfolder sometimes are not moved into
    inbox?

    Any idea what might be wrong?

  2. #2
    Registered User
    Join Date
    Jun 2008
    Location
    Poland
    Posts
    60

    Re: Problem moving intercepted messsage

    Problem fixed, subfolder was not properly created. iServiceId should be KMsvLocalServiceIndexEntryId

Similar Threads

  1. Problem with CAknDoubleStyleListBox with a CAknSearchField
    By jjig in forum Symbian User Interface
    Replies: 2
    Last Post: 2009-09-17, 00:58
  2. Problem with eglSwapBuffers and heap corruption
    By greatape in forum Symbian Media (Closed)
    Replies: 2
    Last Post: 2007-05-24, 03:35
  3. netcards - Problem with opening adapter
    By kernj in forum Symbian Tools & SDKs
    Replies: 5
    Last Post: 2007-01-10, 08:56
  4. Problem: S60 SDK for CW in PC with .NET
    By anttij in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2005-02-28, 11:36
  5. PJava runtime problem within Nokia 9210, Hrlp~!
    By Nokia_Archive in forum PersonalJava
    Replies: 1
    Last Post: 2002-05-28, 13:15

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×