×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    Sep 2009
    Posts
    3

    Question [moved] "Application is not compatible with phone" on 5800

    I'm using s60 5th edition and Carbide 2.0 to try and create an application for my nokia 5800. I've managed to get it running on the emulator, but when I do the phone release build I get the following error when I install it.

    "Application is not compatible with phone. Continue Anyway?"

    I don't want to risk anything on my actual phone, so always say no to this. I've found a few things on the internet about settings in my .pkg file, but I'm not clear as to what I need to change, and how would I do this in Carbide? This is what I have at the moment

    ;Supports Series 60 v 3.0
    [0x101F7961], 0, 0, 0, {"Series60ProductID"}

    Isn't this ok if I'm not using any 5th edition code. I basically just have an "Hello World" type app at the moment.

    I've tried making both a "GUI Application" and a "GUI Application with UI Designer". Is either of these going to be a problem when making an app for the 5800?

    Any help would be much appreciated.

  2. #2
    Registered User
    Join Date
    Sep 2009
    Posts
    3

    Re: "Application is not compatible with phone" on 5800

    After posting this, I found a similar link mentioned below my post (I did do a search for "Application is not compatible with phone", but it didn't find this) that explained that I needed to add this to my .pkg

    ;Supports S60 release 5.0
    [0x1028315F], 0, 0, 0, {"Series60ProductID"}

    Could someone explain why this is needed, and why this isn't made more obvious in the 5th edition SDK? An option in Carbide might be useful, as finding this has been quite annoying.

  3. #3
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,671

    Re: "Application is not compatible with phone" on 5800

    Technically most S60 3rd edition applications could run (or let us say 'start') on S60 5th edition devices. However there are some radical changes (like the lack of keyboard), which may or may not cause difficulties, depending on the input model of the given application.
    Due to that S60 5th edition devices do not claim themselves as compatible with S60 3rd edition - if you want to declare compatibility of your application, specify the S60 5th edition product identifier instead/besides of the S60 3rd edition one: http://wiki.forum.nokia.com/index.ph...fication_codes

  4. #4
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: [moved] "Application is not compatible with phone" on 5800

    This problem is quite easy to solve once you recognize it as an installation problem (nothing to do with Carbide.c++) and start reading the 10 or so lines in the PKG file.

    You do have a point though, maybe some info should be added to the developer library. Let's see what we can do about it.
    Last edited by ltomuta; 2009-10-11 at 20:02.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  5. #5
    Registered User
    Join Date
    Sep 2009
    Posts
    3

    Thumbs up Re: [moved] "Application is not compatible with phone" on 5800

    Thanks for the explanations, and the very quick response! Much appreciated.

  6. #6
    Registered User
    Join Date
    Dec 2009
    Posts
    1

    Re: "Application is not compatible with phone" on 5800

    Quote Originally Posted by ltomuta View Post
    This problem is quite easy to solve once you recognize it as an installation problem (nothing to do with Carbide.c++) and start reading the 10 or so lines in the PKG file.

    You do have a point though, maybe some info should be added to the developer library. Let's see what we can do about it.
    Quote Originally Posted by wizard_hu_ View Post
    Technically most S60 3rd edition applications could run (or let us say 'start') on S60 5th edition devices. However there are some radical changes (like the lack of keyboard), which may or may not cause difficulties, depending on the input model of the given application.
    Due to that S60 5th edition devices do not claim themselves as compatible with S60 3rd edition - if you want to declare compatibility of your application, specify the S60 5th edition product identifier instead/besides of the S60 3rd edition one:
    Dear
    I have nokia 5800 xpress music mobile.

    S60 v5 application download from net. then transfer it ot my mobile. and execute file. but it gives error like: application not supported with this phone. pl reply with useful information to me.

    Other Que: Nokia 5800XM not supported AVI,VOB,MPG,DAT file format. can u give me suggession/technique me for this file formate accept to play in nokia 5800 xpress music.

    Regards,
    Jayesh Patel
    Other Mail Id. jayesh31281@yahoo.co.in
    ----------------------------------------------------------
    Last edited by ltomuta; 2009-12-24 at 09:12. Reason: Made post lisible

  7. #7
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: [moved] "Application is not compatible with phone" on 5800

    This are questions you shoud address to:
    a) the provider of the application which fails to install
    b) Nokia Support (http://www.nokia.com/support) for any issues regarding the use of a Nokia phone (aside from 3rd party apps, as per a) )

    Here's my two cents: the application was not designed to be used with your phone, or at least was not tested accordingly. For applications guaranteed to work use the Ovi Store, while if you really need that particular application and you cannot find it anywhere else, do contact its developer and ask for assistance.

    Nokia phones do not support those file formats but you can easily find a converter to a supported format. AFAIK at least in some regions the CD/DVD provided in Nokia 5800's contains such a converter.

    Forum Nokia is a site for software developers and software development related issues. For end-user discussions see http://www.nokia.com/discussions
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

Similar Threads

  1. 5800 is not compatible with office - problem in device description
    By awoywood in forum Feedback - Nokia Developer Services & Infrastructure
    Replies: 3
    Last Post: 2009-05-26, 10:44
  2. [moved] 5800 help!!!
    By singh_surpreet in forum General Development Questions
    Replies: 2
    Last Post: 2009-04-07, 08:04
  3. Nokia phones are not ready for Bluetooth audio
    By cgraham1 in forum Bluetooth Technology
    Replies: 216
    Last Post: 2008-01-03, 17:52
  4. "application may not be compatible with phone"
    By sbwoodside in forum Symbian
    Replies: 8
    Last Post: 2004-06-21, 03:55

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×