In the S60 5th Edition C++ Developer's Library v2.1 - Platform UID page there should be a note about Carbide.c++'s project templates having the S60 3rd Edition compatibility declared by default and how this may trigger an "Application not compatible with the phone" warning at install time on S60 5th Edition based devices.

See http://discussion.forum.nokia.com/fo...wpost&t=182255