×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Apr 2006
    Location
    Beijing, China
    Posts
    1,175

    Xephyr server Error

    Hi,

    I just installed maemo 5 final sdk on a Ubuntu8.10 in VirtualBox3.0.6(Hosted by WindowsXP). The installation goes well, but when I start Xephyr server, it will complain two errors, one is a font problem(cyrillic font is missed, the required folder does not exist), the other gives this message: "unrecognised device identifier!".

    The detailed information is as follows:
    notroot@notroot-laptop:~$ Xephyr :2 -host-cursor -screen 800x480x16 -dpi 96 -ac -kb &
    [3] 5559
    [2] Done Xephyr :2 -host-cursor -screen 800x480x16 -dpi 96 -ac -kb
    notroot@notroot-laptop:~$ Could not init font path element /usr/share/fonts/X11/cyrillic, removing from list!
    unrecognised device identifier!
    (EE) config/hal: NewInputDeviceRequest failed
    unrecognised device identifier!
    (EE) config/hal: NewInputDeviceRequest failed
    unrecognised device identifier!
    (EE) config/hal: NewInputDeviceRequest failed
    unrecognised device identifier!
    (EE) config/hal: NewInputDeviceRequest failed
    How to fix these errors? Or Can I just ignore them?

    Thank you in advance.
    Way of Simplicity

  2. #2
    Nokia Developer Moderator
    Join Date
    Oct 2009
    Posts
    4,326

    Re: Xephyr server Error

    Those errors are coming from Xephyr settings on your host system.
    It seems that hotplugging is disabled and that' why you have messages
    NewInputDeviceRequest failed. They are quite harmless and you can ignore
    them safely.
    Also it searches for Cyrillic fonts.
    You can see the similar message from Xorg log on the host system.
    $ cat /var/log/Xorg.0.log | grep cyrillic
    (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
    To fix that you need to install Cyrillic fonts (xfonts-cyrillic package in Ubuntu).
    Another option is to ignore this message.

Similar Threads

  1. Animation Example 注释
    By hanwen813 in forum Symbian
    Replies: 1
    Last Post: 2010-08-07, 04:32
  2. XML onLoad with background http server problem
    By simonjuric in forum [Archived] Flash Lite on Nokia Devices
    Replies: 5
    Last Post: 2009-06-08, 16:47
  3. 编译3rd Sample程序时的LINK错误
    By mapk in forum Symbian
    Replies: 9
    Last Post: 2008-06-17, 04:26
  4. compilation error: identifier redeclared
    By netra in forum Symbian C++
    Replies: 2
    Last Post: 2007-06-22, 10:42
  5. Carbide.vs 2.01 Registration Problem
    By baykal in forum Symbian Tools & SDKs
    Replies: 5
    Last Post: 2006-12-22, 16:55

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •