×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    35

    HTTP Comminication with servlet

    Hi, I am trying to get my 7210 emulator to talk to my tomcat server. I have implemented an example midlet and servlet which should talk to eachother fine. In the 7210 emulator I can see it sends and receives a request, however the response has a code of 500: Internal Server Error. I don't know if it is actually contacting my tomcat server or not. I have the "Enable HTTP Connection" tab turned on, and I don't think I need to set a proxy server, although I'm not entirely sure what that is.

    This seems like something that shouldn't be a major problem, but I can't find anything about it anywhere on the web.

    All help much appreciated,

    Thanks, Tommy

  2. #2
    Super Contributor
    Join Date
    Mar 2003
    Location
    Israel
    Posts
    2,280
    You could check two things:
    1) Keep a log from the servlet of all incoming connections. I'm not very familiar with Tomcat but I'm sure there is an option there to keep a log of all incoming requests with the response code they received and maybe even an error message if necessary (most web servers have this option). Even if this option is not available you can always write the servlet so that it keeps a log, saving request URLs as soon as they come in.
    2) Try out the request on a regular browser. Does it also give an error?

    Hope this helps,

    shmoove

  3. #3
    Registered User
    Join Date
    Mar 2003
    Posts
    35
    Thanks! Investigated it further by interacting with the servlet and it was that which was wrong, cheers. Tommy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×