×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Sep 2007
    Posts
    3

    Unhappy XMLHttpRequest problem

    Hi
    I have problem with XMLHttpRequest , in development mode (Firefox) all working fine (i can access remote site)
    but after install on Nokia n95,e71 i can't access my remote site
    in Info.plist i have
    <key>AllowNetworkAccess</key>
    <true />

    What can be problem ?

    attached my XMLHttpRequest function

    function openConnection() {
    var ret_val = "-1";
    xmlHttp = new XMLHttpRequest();

    var url_frame = "http://www.label2.com/root.xml";
    xmlHttp.open('GET', url_frame, false);
    xmlHttp.send();

    if (xmlHttp.status == 200) {
    var items = xmlHttp.responseXML.getElementsByTagName("item");
    ret_val = items.length - 1;
    }

    return ret_val;


    }

  2. #2
    Nokia Developer Champion
    Join Date
    Nov 2007
    Location
    Rome, Italy
    Posts
    2,406

    Re: XMLHttpRequest problem

    Hi kogan_y,

    have you checked if changing the request to be anynchronous can help? (it could also help to avoid the blocking behavior of sync requests)

    Pit

  3. #3
    Registered User
    Join Date
    Sep 2007
    Posts
    3

    Re: XMLHttpRequest problem

    it's working , thanks

  4. #4
    Registered User
    Join Date
    Aug 2009
    Posts
    3

    Re: XMLHttpRequest problem

    I'm having the same problem for synchronous requests. Asynchronous requests works fine though.

Similar Threads

  1. STLPort namespace issue
    By yickhong in forum Open C/C++
    Replies: 0
    Last Post: 2009-04-09, 08:54
  2. SyncML link problem
    By samuel_ in forum Symbian
    Replies: 4
    Last Post: 2009-03-27, 08:02
  3. Problem with eglSwapBuffers and heap corruption
    By greatape in forum Symbian Media (Closed)
    Replies: 2
    Last Post: 2007-05-24, 03:35
  4. netcards - Problem with opening adapter
    By kernj in forum Symbian Tools & SDKs
    Replies: 5
    Last Post: 2007-01-10, 08:56
  5. Problem: S60 SDK for CW in PC with .NET
    By anttij in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2005-02-28, 11:36

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×