Hi all,

I'm working on a project in which I receive calls, put them on hold and issue a
2nd call to our company PBX (Cisco). Whereas the first 2 steps are carried out
manually, the last one (issuing the new call) is done with an application I
wrote. The 2nd call is created by using CTelephony. Originally, I tested this
with a Nokia E51, and it works great! No problems at all, 2 calls
simultaneously, one on hold, the other active.

Now, the company decided to buy new Nokia E52s (new at least in Germany) and
here we're facing a serious problem.

Imagine a call coming in. The user accepts it and after exchanging a few words
with the caller he puts the call on hold (all manually, eg. pressing the
"green" button twice, no new application involved).
Now, he switches to my app and let it issue a 2nd call to our PBX. On the E51
I can see that I have one call on hold (the first one) and a 2nd one (to the
PBX) which is active. On the E52, however, I can only see the first call. No
sign of the other (active) call at all. Therefore, when I press the "end-call"
button, the first one is gone. But the real problem is that the 2nd (active)
call is still active! From there on, there is no way to gain control over this
call again, the phone simply looks as if there is no call at all. Still, the
phone connected to the PBX (ringing). To end this "vanished" call I have to
reboot the phone...

In order to add to the confusion: Before accepting and holding a call I tried
the following... I issued a call with my application (using CTelephony) to our
PBX (or somewhere else, doesn't matter). After that, everything is fine on the
E52 again: Accepting and holding the call, issuing the 2nd one, and I can see
both calls, can switch between them, etc.

The E52 is 3rd edition FP2, the E51 is FP1. I already tried to compile my
application with FP2, no success, though.

What can this be? A firmware problem?
Please give me a hint, any help is appreciated! I'm kind of desperated...

Best
-Eric