×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Jun 2009
    Posts
    11

    Sound error 7 when swf is packaged as a sis

    We have developed an animated app for the red cross .swf works fine on our test phone E75 but when i package it up into a .sis file all is fine icon works and looks good, .swf runs fine until incoming call test then we get an error 7 message. Passes same test if we just run the animation from the .swf. Only happens when .swf launched from the icon in app's - why is this?

  2. #2
    Nokia Developer Champion
    Join Date
    Jul 2008
    Location
    Pakistan
    Posts
    1,065

    Smile Re: Sound error 7 when swf is packaged as a sis

    Error 7 refers to "Bad Sound Data" .I also observed such kind of behavior before , when my app contains sound + animation and a call arrives . Symbian OS gives incoming calls a priority over any app running in the phone & flash lite pauses instantly when it goes to background + Memory of flash lite apps are limited. So, may be certain calls can play this trick. However, according to ur feedback, it seems to be a stub issue. If u have understanding of Symbian C++, then u can try to create a launcher using CDocumentHandler which may solves ur issue because in case of CDocumentHandler the flash player gets embedded in your c++ app and opens the provided swf file into it .So, it should behave the same as standalone Flash Player .

    Best Regards,
    SajiSoft

  3. #3
    Registered User
    Join Date
    Jun 2009
    Posts
    11

    Re: Sound error 7 when swf is packaged as a sis

    Hi sajisoft thanks for this unfortunately I'm no c++ person and have no Idea what your on about, but it was good of you to respond much appreciated, we are still trying to resolve the issue, it cant be that heard, swf plays fine when launched and no problem with incoming call, surly the icon in apps just launches same? but thats when the fun and games start.
    Steve

  4. #4
    Nokia Developer Champion
    Join Date
    Jul 2008
    Location
    Pakistan
    Posts
    1,065

    Smile Re: Sound error 7 when swf is packaged as a sis

    Quote Originally Posted by sgone View Post
    Hi sajisoft thanks for this unfortunately I'm no c++ person and have no Idea what your on about, but it was good of you to respond much appreciated, we are still trying to resolve the issue, it cant be that heard, swf plays fine when launched and no problem with incoming call, surly the icon in apps just launches same? but thats when the fun and games start.
    Steve
    This question is related to C++ again. Just a little note, two type of swf launchers can be made:
    1- One which uses FLash Lite UI Framework Api known as stub.
    2- One which doesnt use FLash Lite UI Framework Api known as launcher.
    Online packaging services use the first one. The second one is also available in online packaging service but it is only for preimium users .However, the maximum favor i can do for u is that u can submit me a testing swf file and i will make a swf launcher for u using second technique and then we can test whether this is the issue or not.

    Best Regards,
    SajiSoft

  5. #5
    Registered User
    Join Date
    Jun 2009
    Posts
    11

    Re: Sound error 7 when swf is packaged as a sis

    Hi SajiSoft - Still having same issues, been making sure the sound file used in the animation is within paramiters. I will send you a sample of the .swf file im using if you are still happy to help me out
    Kindest Regards
    Steve

Similar Threads

  1. Volume keys when SWF installed using SIS
    By Jii5Hoo in forum [Archived] Flash Lite on Nokia Devices
    Replies: 0
    Last Post: 2009-03-26, 08:23
  2. Multiple programs within single SIS file dilema
    By LongSteve in forum Symbian
    Replies: 6
    Last Post: 2008-03-20, 06:05
  3. Can AppTestLite test my sis?
    By truf in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 1
    Last Post: 2007-08-24, 14:02
  4. Mobile Virus Info and Solution
    By kunalshastry in forum General Development Questions
    Replies: 16
    Last Post: 2007-08-07, 11:12
  5. Replies: 0
    Last Post: 1970-01-01, 02:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •