×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Regular Contributor
    Join Date
    Sep 2009
    Posts
    285

    Error creating app : '- - icon' option not creating icon

    Hi!

    I am trying to create a sis file out of a simple python script (called test.py) i have written. I am following the instructions given here.

    I am working on a machine running windows. I gave the following command in the command prompt -
    python ensymble_python.py py2sis --uid=0xExxxxxxx
    --icon=myicon.svg --appname="MyApp" --shortcaption="My App."
    --caption="My Application" --version=1.2.3 --verbose test.py
    The svg file here is a black square which I am using for testing purposes.

    I also tried the same command using a jpeg image - the same black square of size 44x44 pixels. I gave the command -
    python ensymble_python.py py2sis --uid=0xExxxxxxx
    --icon=test.JPG --appname="MyApp" --shortcaption="My App."
    --caption="My Application" --version=1.2.3 --verbose test.py
    However, in both cases, I don't see any icon.

    Is there any way to get the icon? Will older versions of ensymble work better? Please help!

    Update :
    If I extract the contents of the .sis file and extract the image out of the .mif file, I can see the image (the black rectangle). This is a svg file.

    Phone details :
    Nokia N73 running Python 1.4.5 (Runtime and shellscript)
    Last edited by kedarm; 2009-11-20 at 09:39.

  2. #2
    Regular Contributor
    Join Date
    Sep 2009
    Posts
    285

    Re: Error creating app : '- - icon' option not creating icon

    Hi!

    For some reason, I just cannot give my application an icon. I just wanted to update my previous post with some of the other stuff I tried.

    Using SISContents:
    1) I downloaded an application from the net and opened it using SISContents.
    2) I chose the "Edit Package" in the "Tools" menu.
    3) I opened the .mif file and replaced the image already present ('Entry 01.svg') with a random image I had generated (called 'Entry 01.svg').
    4) Signed the package (using the self-signing tool) and saved it.
    5) Installed the package on the computer.
    However, the new package does not have any icon!

    I then tried to undo what I had done.
    1) I opened the application I had newly created
    2) I chose "Edit Package" from the "Tools" menu
    3) I opened the .mif file and replaced the 'Entry 01.svg' image with the original 'Entry 01.svg' image.
    4) Signed the package, saved it and installed it on the phone.

    The package STILL does not have any icon.

    How do I give an icon to my application? Please help!

  3. #3
    Super Contributor
    Join Date
    Nov 2007
    Location
    Sertaozinho/Brazil
    Posts
    768

    Re: Error creating app : '- - icon' option not creating icon

    kedarm


    I am not sure if the same rules for icons in MIF files should be applied to application icons. For MIF, the format must be tiny SVG and some features are not support. My MIF files are generated using this tutorial.

    I hope it helps.

    Marcelo

  4. #4
    Regular Contributor
    Join Date
    Sep 2009
    Posts
    285

    Re: Error creating app : '- - icon' option not creating icon

    Hi!

    I tried following the steps mentioned in the tut :

    1) I created an image of size 44x44 pixels
    2) I used the svg2svgtconverter tool to convert it to svgt.
    3) i added the viewBox option

    However, when I issue the following command, I still get a sis without an icon!
    D:\data_matrix\testbox\app_icon\app_icon>python c:\sisinfo\ensymble.py py2sis --
    uid=0xE4211998 --appname="App Name" --shortcaption="Sh. Cap" --caption="Caption"
    --icon=test.svg --verbose a1.py
    I also tried the following - using siscontents, I opened up another application and just for testing purposes, used the extracted svg icon file. It works!
    So, I guess there is nothing wrong with the command (as I initially feared) but something wrong in the way I am creating my svg image.

    Is there any other way to create a svg image that is compatible?

  5. #5
    Super Contributor
    Join Date
    Nov 2007
    Location
    Sertaozinho/Brazil
    Posts
    768

    Re: Error creating app : '- - icon' option not creating icon

    kedarm

    There is a cache for images in menus,at least for S60 phones. Have you rebooted your phone ?

    Marcelo

Similar Threads

  1. Creating a "skinnable" app
    By Buffel in forum Mobile Java Media (Graphics & Sounds)
    Replies: 0
    Last Post: 2009-01-30, 12:37
  2. Dynamically Creating Icon for list
    By SimonJudge in forum Symbian Media (Closed)
    Replies: 2
    Last Post: 2008-09-09, 15:40
  3. how to get app icon
    By hsany330 in forum Symbian User Interface
    Replies: 1
    Last Post: 2008-08-22, 13:15
  4. Problem in build with S60 1FP
    By Manuelito_ in forum Symbian Tools & SDKs
    Replies: 14
    Last Post: 2007-09-18, 12:08

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×