×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    27

    Installing Maemo SDK+ on a 64 bit system.

    I don't seem to be able to find much here about Maemo. Am I in the right place?

    I seem to be having a bit of trouble installing the Maemo SDK+.
    I have a 64 bit system, which is what basically everyone is starting to have nowadays.
    (I am running Fedora 12)
    The latest SDK installs from some Python scripts which have to be run as root.
    When I execute the GUI Installer script, the latest "final" Maemo SDK complains I have SELinux
    and a 64 bit system and that it runs on only 32
    bit systems. I find somewhere by Googling that I need Maemo SDK+, which uses Scratchbox 2.
    When I try to go to Maemo SDK+, I end up back at the original place where the Python scripts are.

    I also tried to download the Maemo SDK VM image. It is from a 3rd party, it seems.
    It seems to be zipped with the Windows program 7-Zip, and is targeted at Ubuntu. After an hour
    of reading the 7za man page (ugh), Googling, and trying 7za, I still couldn't get
    the split file to unzip. I suppose I could try putting the files on a Windows computer and unzipping them there...
    or install 7-zip using Wine...

    This is difficult!

  2. #2
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Installing Maemo SDK+ on a 64 bit system.

    Hi frostybeard,

    thanks for the feedback. Yes, you are at the right place, or rather you will be We're ramping-up the Maemo applications developers support but meanwhile most of the useful information is likely to be found on the platform development site, over at http://www.maemo.org

    I will pass on this report of install problems on 64bit systems.

    As for the virtual image I guess 7z was preferred for better compression ratio but I'm surprised to hear there is a data compatibility issue with this archiver. Based on the instructions provided it seems to be that they have used a Linux build of the archiver to pack the file, probably you should just make sure that you have the latest version. Also I'm not sure what the relationship between 7z and 7za is, the install instructions recommend the former.
    user@machine$: 7z x Maemo_Ubuntu_Intrepid_Desktop_SDK Virtual_Image.zip.001
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

Similar Threads

  1. How to enable actual SOAP/XML payload logging
    By maulik67 in forum General Messaging
    Replies: 4
    Last Post: 2004-12-15, 20:45
  2. Installing PC connectivity SDK 1.0 for Nokia Card Phone 2.0
    By psmshankar in forum Multimodecards
    Replies: 1
    Last Post: 2002-07-25, 05:06
  3. Problem in installing Nokia PC Connectivity SDK 1.0
    By psmshankar in forum PC Suite API and PC Connectivity SDK
    Replies: 1
    Last Post: 2002-07-25, 00:38
  4. Installing Nokia PC Connectivity SDK 1.0 for Nokia Card Phone 2.0
    By psmshankar in forum PC Suite API and PC Connectivity SDK
    Replies: 1
    Last Post: 2002-07-18, 04:42
  5. Installing SDK on windows 2000
    By misola in forum Symbian
    Replies: 4
    Last Post: 2002-06-25, 17:35

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×