×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    Dec 2009
    Posts
    10

    Angry Development environment

    Since Qt 4.6 is out and there are video tutorials for installing necessary things I did another try. I followed every step and removed previously installed versions.

    After writing a test application I'm trying to compile but get the following output:

    Code:
    make[2]: *** No rule to make target `\S60\devices\S60_5th_Edition_SDK_v1.0_4\epoc32\release\ARMV5\urel\qtmain.lib', needed by `\S60\devices\S60_5th_Edition_SDK_v1.0_4\epoc32\release\gcce\urel\testapp2.exe'. Stop.
    make[1]: *** [TARGETTESTAPP2_0XE4800095] Error 2
    So what does that mean?

  2. #2
    Nokia Developer Moderator
    Join Date
    May 2007
    Posts
    468

    Re: Development environment

    Did you solve this already?

    Jack

  3. #3
    Registered User
    Join Date
    Dec 2009
    Posts
    10

    Re: Development environment

    nope, still not

  4. #4
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Development environment

    Might be that as you have installed multiple versions of S60_5th_Edition_SDK_v1.0_x so Qt Setup might not be able to copy required files to required places . you might want to cleanup your Development machine or try copying qt files manually.

  5. #5
    Registered User
    Join Date
    Dec 2009
    Posts
    10

    Re: Development environment

    As you can see I reinstalled the whole system multiple times I also removed previously installed files each time. But somewhere the SDK seems to store links to the already removed SDK because the installer always wants to install to S60_5th_Edition_SDK_v1.0_x+1. I even deleted the \Shared files\Nokia by hand because they were not de-installed. Maybe I should try next time to remove the _x from the installation part of the SDK. ...hope dies last.

  6. #6
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Development environment

    Quote Originally Posted by kwin View Post
    As you can see I reinstalled the whole system multiple times I also removed previously installed files each time. But somewhere the SDK seems to store links to the already removed SDK because the installer always wants to install to S60_5th_Edition_SDK_v1.0_x+1. I even deleted the \Shared files\Nokia by hand because they were not de-installed. Maybe I should try next time to remove the _x from the installation part of the SDK. ...hope dies last.
    it also has been discussed more then once in Symbian.C++ section just for your referance http://skumarmobiledev.blogspot.com/...ions-foot.html

  7. #7
    Registered User
    Join Date
    Dec 2009
    Posts
    10

    Re: Development environment

    Thank you skumar_rao, I tried so many times to get a running development environment and now it works. I removed that curious registry key which is mentioned in your linked page, that really solved the problem!

Similar Threads

  1. 伊莱比特无线技术(北京)有限公司招聘
    By EB in forum Publish to Nokia Store发布到诺基亚应用商店
    Replies: 0
    Last Post: 2007-10-21, 09:01
  2. Setting up development environment
    By kalkar.prashant@gmail.com in forum Mobile Java Tools & SDKs
    Replies: 10
    Last Post: 2007-09-30, 09:09
  3. Latest Trend on Symbian Development Environment?
    By shanif in forum Symbian C++
    Replies: 1
    Last Post: 2003-05-07, 12:42
  4. Latest Trend on Symbian Development Environment?
    By shanif in forum Symbian C++
    Replies: 0
    Last Post: 2003-05-06, 08:47
  5. MMS Application development and testing environment.
    By khurshed79 in forum General Messaging
    Replies: 1
    Last Post: 2002-09-28, 15:39

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •