×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Registered User
    Join Date
    Apr 2003
    Posts
    4

    java.rmi.ConnectException: Connection refused to host:

    java.rmi.ConnectException: Connection refused to host:
    I have installed Borland Enterprise Server, Nokia Mobile Server Services SDK and the SDK library 1.0.1.

    I am able to commence the Borland Enterprise Server but when I attempt to run http://<<computer_name>>/sadk/applet.html the applet begins to load and displays an error:

    "Connection refused to host: <<computer_name>>; nested exception is..."
    "java.rmi.ConnectException: Connection refused to host: <<computer_name>>; nested exception is: java.net.ConnectException: Connection refused: connect"

    What is causing the exception????

    I am running on Windows XP Professional and am running a LAN at home with my computer being the gateway to the Internet for the other computer.

    I have installed C:\jdk1.3.1_07 and have set up my environment variables as follows:
    JAVA_HOME=C:\jdk1.3.1_07
    PATH=C:\jdk1.3.1_07\bin;<<SYSTEM_STUFF>>C:\BorlandEnterpriseServer\bin
    I have no CLASSPATH currently set

    Can anyone please tell me what is causing the exception above?

  2. #2
    Registered User
    Join Date
    Mar 2003
    Posts
    13
    Hi,

    I had a similar problem when I first installed everything. You have to go with all of the BES and Nokia defaults except for the option to include the BES bin directory in your path - change this to yes, and then you should be fine. If you don't go with the default server name, then the link can't find the applet. Alternatively, you can do a search for applet.html and launch it yourself but you may encounter other problems later on - I found re-installing with all bar one (bin in path) of the defaults worked for me.

    Hope this helps!
    Susan

  3. #3
    Registered User
    Join Date
    Apr 2003
    Posts
    4
    I have tried installing and re-installing Borland Enterprise Server, Nokia Mobile Server Services SDK and the SDK library 1.0.1 several times with and without defaults and have once again tried as you have stated to allow BES to include the BES bin directory in your path but it still does not work.

    I am thinking that there may be a problem due to the LAN settings. My computer is using 2 NIC cards and is the gateway to the Internet for the other computer. Both computers are running Windows XP with recent clean installs and the second computer is a laptop. I'm not sure if this helps at all.

  4. #4
    Nokia Developer Expert
    Join Date
    Mar 2003
    Location
    Tampere / Finland
    Posts
    1,839
    Hello!

    We have developed the Server Services emulator only for Windows 2000 environment. We can't help you when using Win XP.

    Teemu / Forum Nokia

  5. #5
    Registered User
    Join Date
    Mar 2003
    Posts
    13
    Hi,

    I'm using Windows XP, and it works fine. Perhaps the fact that your machine is the gateway to the Internet for another computer is causing the problems?

    Susan

  6. #6
    Registered User
    Join Date
    Apr 2003
    Posts
    4
    I have tried disconnecting the network by physically removing the connecting NIC card and removed all references that I know of to the connection and I still get the same error!!!!

    A friend of mine has Windows XP and had NO problems installing and running the emulator. He has no network at home and also has cable Internet.

    I am getting extremely frustrated and do not know what to try next.

  7. #7
    Registered User
    Join Date
    Mar 2003
    Posts
    4
    I have the same problem!
    I'm using Windows 2000 with J2SDK 1.4.2_01
    When I run Emulator GUI, the server has some exception: SocketException : write to socket error.....
    then the client(applet) will show Connection refuse....
    How can I run Emulator GUI?

  8. #8
    Registered User
    Join Date
    Jan 2004
    Posts
    1
    java.rmi.ConnectException: Connection refused to host:

    I had this same error, and did not find any solutions on the boards so I'll post how got around it.

    It seems that the security settings of the web browser were preventing the RMI connection.

    To avoids this I used the appletviewer on the page instead:
    appletviewer http://<<computer_name>>/sadk/applet.html

    I imagine lowering the security on your browser would also work.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •