×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Dec 2008
    Posts
    5

    Exclamation QT for S60 project build error

    Hi,

    I met a problem when I build my first QT for S60 project. The errors is like below:
    Running build steps for project TestQTConsole...
    Starting: c:/qt/4_6_0/bin/qmake.exe C:/QTProject/TestQTConsole/TestQTConsole.pro -spec symbian-abld -r
    Exited with code 0.
    Starting: C:/Symbian/9.3/S60_3rd_FP2_Beta/epoc32/tools/make.exe -w
    C:\Symbian\9.3\S60_3rd_FP2_Beta\epoc32\tools\make.exe: Entering directory `C:/QTProject/TestQTConsole'
    bldmake bldfiles
    ABLD.BAT build winscw udeb
    make -r -f "\Symbian\9.3\S60_3rd_FP2_Beta\EPOC32\BUILD\QTProject\TestQTConsole\EXPORT.make" EXPORT VERBOSE=-s
    make[1]: Entering directory `C:/QTProject/TestQTConsole'
    Nothing to do
    make[1]: Leaving directory `C:/QTProject/TestQTConsole'
    make -r -f "\Symbian\9.3\S60_3rd_FP2_Beta\EPOC32\BUILD\QTProject\TestQTConsole\WINSCW.make" MAKEFILE VERBOSE=-s

    WARNING: Can't find following headers in System Include Path
    <string> <iterator> <list> <new>
    (Sys Inc Paths "\Qt\4_6_0\include\QtCore\" "\Qt\4_6_0\include\QtCore\tmp\" "\Qt\4_6_0\include\" "\Qt\4_6_0\include\tmp\" "\Qt\4_6_0\mkspecs\common\symbian\" "\Qt\4_6_0\mkspecs\common\symbian\tmp\" "\Symbian\9.3\S60_3rd_FP2_Beta\epoc32\include\" "\QTProject\TestQTConsole\" "\QTProject\TestQTConsole\tmp\" "\Symbian\9.3\S60_3rd_FP2_Beta\epoc32\include\stdapis\" "\Symbian\9.3\S60_3rd_FP2_Beta\epoc32\include\stdapis\sys\" "\Symbian\9.3\S60_3rd_FP2_Beta\epoc32\include\variant")
    Dependency list for "\QTProject\TestQTConsole\main.cpp" may be incomplete


    Thanks your help

  2. #2
    Regular Contributor
    Join Date
    Dec 2009
    Posts
    77

    Re: QT for S60 project build error

    make sure you have latest Open C/C++ plugin installed in your sdk.
    And you default sdk is to the sdk you are working on.

  3. #3
    Super Contributor
    Join Date
    Oct 2007
    Location
    જુનાગઢ - India
    Posts
    3,034

    Re: QT for S60 project build error

    Why are you trying to use beta version of Symbian SDK?? Instead use S60 3rd Edition SDK for Symbian OS, Feature Pack 2.

Similar Threads

  1. Build Error on Carbide
    By deepak_pious in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 3
    Last Post: 2010-05-23, 09:37
  2. Problem in resolving Build error prj0019
    By psandhu in forum Symbian
    Replies: 2
    Last Post: 2008-10-07, 14:30
  3. undefined symbol error during build the project
    By kannabiran.krish in forum Symbian
    Replies: 1
    Last Post: 2007-08-13, 13:44
  4. S60 2nd FP3 thumb build problem
    By ravi.77 in forum Tools and SDK Feedback (Closed)
    Replies: 0
    Last Post: 2006-11-07, 06:04

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×