×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    20

    Please help with MIME types

    Hi there,

    I think I'm losing my mind so please help me!

    I have a test file on my server at www.mrbadger.com/test.xhtml

    When I view it locally on the toolkit 3.1 it works fine. When I point the toolkit to the url, it works fine. (it ought to, its practically the default blank file!) So, up to this point all is going well.

    However, on a 7650 pointed at the url I get error 406: Unsupported Content

    When I point Nokia Simapp 2.0 at the url I get the error: WML Browser: Unsupported Content.

    I understand that this may be down to MIME Type configuration. So I've spoken to my isp and they have told me how to define MIME Types on my server. The instructions for doing this are online at http://www.washington.edu/webinfo/htaccess/

    So, I've created a .htaccess file which contains the lines:

    AddType text/html xhtml
    AddType application/xhtml+xml xhtml
    AddType application/vnd.wap.xhtml+xml xhtml

    As this is what I could understand from the Nokia XHTML guidlines doc.

    However, it still doesn't work. I still get the same errors. And now I'm going insane. My head hurts and my stomach is tight. My girlfriend is pregnant and my whole world is hell

    When I validate test.xhtml locally using http://validator.w3.org it says the code is fine. When I use the same validator on the online file I'm told 'Sorry, I am unable to validate this document because its content type is application/vnd.wap.xhtml+xml, which is not currently supported by this service.' Fair enough I guess, but not much help to a nivice like me...

    I don't know very much about this sort of thing at all. I've been learning XHTML as I go and don't really know anything about the server side of things.

    Please help me somebody!!!

    thanks in advance

    Rich

  2. #2
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    196
    Hi,

    Nokia 7650 has WAP 1.2.1 browser and it does not support XHTML. Check from Nokia GSM WAP phone characteristic document which Nokia WAP Phones support XHTML

    Pete

  3. #3
    Registered User
    Join Date
    Mar 2003
    Posts
    20
    Good point! Thanks for that.

    Do you have any idea why when I use sim app and open the file locally it works, but when I browse to it online I get 406: Unsupported Content?

    thanks

    Rich
    Last edited by mrbadger; 2003-04-09 at 17:26.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •