×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    3

    Nokia 22:How to read CLI over RS232?

    Hi,

    Could you please advise how to read CLI information
    from Nokia 22 connected to a PC over RS232?
    I have put the following AT commands into the Nokia 22 using Hyper Terminal but nothing happens during incoming GSM call
    AT+CLIP=1;+CRC=1
    Or should I do anything else to receive the CLI?

    Thank you.

  2. #2
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    439

    CLIP

    Dear Customer,

    note that if you make a voice call to voice number, the call will be routed to the line adapter (trunk or extension interface).

    Please try the following:
    - switch power off
    - separate the upper part of N22 from lower part
    - switch power on
    - enter AT+CLIP=1;+CRC=1
    - call to the number of SIM card
    - check if you can see the caller ID

    If you see it now, the reason is the voice call that was routed to line adapter. If you want to use the voice number, and the line adapter is not needed, you can switch the N22 to fixed RS-232 mode where all calls are routed to RS-232 interface. It can be done with a Configurator SW (more information about that from your N22 reseller) or by dialing *3282# with a telephone set connected to trunk interface.

    Kind Regards,
    Nokia M2M developer support team

  3. #3
    Registered User
    Join Date
    Mar 2003
    Posts
    3

    Many thanks for the tip!!!

    Yes it works when without line adapters.

  4. #4
    Registered User
    Join Date
    May 2003
    Posts
    1

    disabling CLIP

    Goodafternoon,

    My question is pretty similar to this problem. Our company uses a Nokia 22 as a mobile gateway. I want to disable CLI of the SIM-card in my Nokia 22. Our provider advised us to transfer the SIM-card to a mobile phone, then disable CLI through the menu, and then put the SIM-card back in the Nokia 22. This did not work.

    Inspired by this forum, I dowloaded Hyperterminal and bought a RS232 wire the connect the Nokia 22 with my laptop. Still, I am not able to disable CLI. What have I done wrong? This is my method:

    - disconnecting power of Nokia 22
    - disconnecting PBX trunkline
    - connecting RS232 with Nokia 22
    - connecting power with Nokia 22
    - opening Hyperterminal
    - connecting COM1 port
    - port setting: default
    - (writing in Hyperterminal screen AT+CLIP=0
    << often I receive error messages, I sometimes try the command
    AT+CLIR=1; which ought to invocate CLI restriction, but this doesn't work either>>

    How can I receive a confirmation of the fact I disabled CLI and why does the CLI-restriction not work?

    Sincerely,

    Martin Stam

  5. #5
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    439

    N22 CLIR

    Dear Customer,

    it is possible to activate the CLIR only by service provider.

    Regards,
    M2M developer support team

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×