×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Jan 2006
    Posts
    3

    Instrumented plugins cannot be loaded

    Hi everyone

    I have had problems loading plugins instrumented with code coverage tools. The QPluginLoader seems to crash when it tries to load an instrmented plugin.
    For instrumentation I have been using vsinstr (tool in visual studio), ctc++ and Bullseye coverage and only bullseye have worked.

    Have anybody had same experinces.

  2. #2
    Regular Contributor
    Join Date
    Sep 2008
    Posts
    286

    Re: Instrumented plugins cannot be loaded

    Hi,
    Can you see what code the instrumentation generates? I would assume that the generation in non-working coverage tools adds arguments to functions/changes return types which would cause behaviour you are observing.

    You can propably make an example application not using Qt and still get the same issue. plugins are load at at runtime by calling entrypoint function (factory) and then API is virtual table.

    Check the map files generated and compare to non-instrumented ones.

    -Janne

Similar Threads

  1. PC Suite error: (Code: Init IMediaControl2) HELP?!
    By chunkyspudmonkey in forum General Development Questions
    Replies: 30
    Last Post: 2014-07-15, 05:44
  2. ECOM plugins not loaded on device
    By SymbianDev in forum Symbian
    Replies: 8
    Last Post: 2009-02-09, 05:26
  3. Linker crash while building
    By suvarnas in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2008-03-13, 21:06
  4. Prototype SDK 2.0 setup problem
    By jackmcardle in forum Mobile Java Tools & SDKs
    Replies: 4
    Last Post: 2007-01-09, 16:21
  5. SDK2.1 Installation Caveats
    By Sukrit in forum Symbian Tools & SDKs
    Replies: 8
    Last Post: 2004-08-11, 11:20

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×