×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Nov 2009
    Posts
    7

    Installing Mobility Project Problem

    Hi,

    I am trying to install the mobility project . I used 2 approaches and have reached a dead end .

    I tried the deployment of prebuilt binaries . The zip file unloaded the libraries into C:\Symbian\9.2\S60_3rd_FP1\epoc32\release\armv5 . When i try to compile my project I get the following error:-

    WARNING: Can't find following headers in System Include Path
    <qgeopositioninfo.h> <qgeopositioninfosource.h>
    (Sys Inc Paths "\Qt\4.6.0\include\QtCore\" "\Qt\4.6.0\include\QtCore\tmp\" "\Qt\4.6.0\include\QtNetwork\" "\Qt\4.6.0\include\QtNetwork\tmp\" "\Qt\4.6.0\include\QtGui\" "\Qt\4.6.0\include\QtGui\tmp\" "\Qt\4.6.0\include\QtXml\" "\Qt\4.6.0\include\QtXml\tmp\" "\Qt\4.6.0\include\" "\Qt\4.6.0\include\tmp\" "\Qt\4.6.0\mkspecs\common\symbian\" "\Qt\4.6.0\mkspecs\common\symbian\tmp\" "\Symbian\9.2\S60_3rd_FP1\EPOC32\include\" "\foursquares\" "\foursquares\tmp\" "\Symbian\9.2\S60_3rd_FP1\EPOC32\include\stdapis\" "\Symbian\9.2\S60_3rd_FP1\EPOC32\include\stdapis\sys\" "\Symbian\9.2\S60_3rd_FP1\EPOC32\include\stdapis\stlport\" "\Symbian\9.2\S60_3rd_FP1\EPOC32\include\oem\" "\Symbian\9.2\S60_3rd_FP1\epoc32\include\variant" "C:\Program Files\CSL Arm Toolchain\bin\..\lib\gcc\arm-none-symbianelf\3.4.3\include\")

    Second i tried to use the "configure.bat" . That throws an unexpected error while checking for make ( which is in the PATH ) .

    Are there some other steps that I have to take to get the set up right ?

    Thanks

  2. #2
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Installing Mobility Project Problem

    i suggest you check if make is available on your machine .

  3. #3
    Regular Contributor
    Join Date
    May 2007
    Posts
    468

    Re: Installing Mobility Project Problem

    The install.txt in symbian folder describes what you need to do.
    Also in http://wiki.forum.nokia.com/index.ph...nology_Preview

    1) unzip the libraries
    2) run "configure -examples" from command prompt
    3) build a ready example to ensure your setup works

    Let us know if you have further problems.

    Jack

  4. #4
    Registered User
    Join Date
    Nov 2009
    Posts
    7

    Re: Installing Mobility Project Problem

    Hi guys,

    thanks for the suggestions . I made sure make is under my PATH . I am running configure using QT command prompt , and when i try to build the examples I get the same error "Checking make and unexpected error at this time " . Make is installed bec i can get the version number and compile other qt projects.

  5. #5
    Registered User
    Join Date
    Nov 2009
    Posts
    7

    Re: Installing Mobility Project Problem

    Figured it out guys . I copied the folder at the same level as the symbian sdk and then ran it . Worked flawlessly .

    So if your sdk location is C:\Symbian\SDK_v , unzip the folder at C:\QTMobility.

    Thanks

Similar Threads

  1. 编译Qt样例出错,请看如下
    By TD3 in forum [Archived] Qt General ( Qt技术)
    Replies: 14
    Last Post: 2009-12-24, 03:23
  2. ViewSrv 11 problem WINSCW, WINS project build options
    By Embedded Guy in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 15
    Last Post: 2009-06-29, 10:57
  3. Problem with importing project
    By nuker85 in forum Symbian
    Replies: 4
    Last Post: 2008-05-24, 21:03

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×