×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Jul 2009
    Posts
    2

    Unhappy can't install maemo-sdk-install_5.0.sh,help

    When I install maemo 5 on redhat9 Linux,
    I have installe
    d the scratchbox into directory /scratchbox,and make the user root into group,but I want to install sdk,there are error as follows,please help me,thank you very much!

    [root@localhost tmp]# sh maemo-sdk-install_5.0.sh
    This script will install maemo SDK 5.0 fremantle release to your computer.

    Install options
    Force remove of existing targets (no)
    Alternative sources.list ('')

    Target configuration for armel (FREMANTLE_ARMEL)
    compiler=cs2007q3-glibc2.5-arm7
    devkits=perl:debian-etch:qemu:doctools:svn:git
    cputransp=qemu-arm-sb

    Target configuration for i386 (FREMANTLE_X86)
    compiler=cs2007q3-glibc2.5-i486
    devkits=perl:debian-etch:doctools:svn:git

    Checking for prerequisites
    --------------------------

    wget tool in path... /usr/bin/wget
    Checking for dpkg tool in path... which: no dpkg in (/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/root/bin:.)
    not found.
    Running outside of scratchbox... yes
    Script not run as user root... no
    E: This script should NOT be run as user root.

  2. #2
    Super Contributor
    Join Date
    Oct 2009
    Posts
    4,326

    Re: can't install maemo-sdk-install_5.0.sh,help

    SDK is officially supported for Debian i386, so using in on Red Hat 9 won't be the same.
    There are some guides on the net how to setup and run SDK with different Fedora versions (which is successor of Red Hat distribution):
    http://aalonso.wordpress.com/2008/11...1-on-fedora-9/

Similar Threads

  1. SDK Install error
    By edy_3dz in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2008-12-30, 07:37
  2. Problems about maemo 4.0.1 SDK installation.
    By fgg_maemo in forum General Development Questions
    Replies: 3
    Last Post: 2008-10-07, 14:26
  3. [moved] Impossible Install Carbide 3.01; The setup not see Nokia Sdk
    By nicola.moscardo in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2008-08-31, 12:48
  4. Series 60 Concept Emulator (SDK Beta 0.2 Linux) not working
    By mattbee in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2003-06-10, 11:43

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •