I used normal DES algorithm for encryption and decryption
Do the java.security and javax.crypto is supported in j2mepolish.JSR 177.jar file added to j2mepolish/import and binarylibraries.
its giving the error

Warning: unable to resolve path to API "jsr75". When this leads to problems, please register this API in [apis.xml].
Warning: unable to resolve path to API "jsr177". When this leads to problems, please register this API in [apis.xml].
package java.security does not exist
import java.security.InvalidKeyException;

import java.security.NoSuchAlgorithmException;

package javax.crypto does not exist

import javax.crypto.BadPaddingException;
import javax.crypto.Cipher;
import javax.crypto.IllegalBlockSizeException;
import javax.crypto.NoSuchPaddingException;


when used in normal j2me then there is no error. when App+j2mepolish then its giving error.
Actually i have to use in Triple DES that is not working in normal APP later i have used DES algo its working fine in normal app but when used j2me polish its giving the following above errors.

Please Anyone give me the solution.