×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Mar 2009
    Posts
    19

    5800 widget redirect to other page problem

    Dear all,

    when the widget run in 5800,the index page can redirect to google,but when redirect to index2 page, the index2 page can't redirect to google. then return to index page, also can't redirect to google. below is the code. pls give me some advise. Thanks!

    index.html
    <html>
    <head>
    <script language="javascript">
    function doRedirect(url)
    {
    alert(url);
    widget.openURL(url);
    }
    </script>
    </head>
    <meta http-equiv="cache-control" content="no-cache" />
    <link href="style.css" rel="stylesheet" type="text/css">
    <table>
    <tr>
    <td>
    <a href="index2.html">link</a>
    <a href="http://www.google.com">google</a>
    </td>
    </tr>
    </table>
    <table>
    <tr>
    <td>
    <img src="images/custom.png" onClick="doRedirect('http://www.google.com')">
    </td>
    </tr>
    </table>
    </html>

    index2.html
    <html>
    <head>
    <script language="javascript">
    function doRedirect(url)
    {
    alert(url);
    widget.openURL(url);
    }
    </script>
    </head>
    <meta http-equiv="cache-control" content="no-cache" />
    <link href="style.css" rel="stylesheet" type="text/css">
    <table>
    <tr>
    <td>
    <a href="index.html">link</a>
    <a href="http://www.google.com">google</a>
    </td>
    </tr>
    </table>
    <table>
    <tr>
    <td>
    <img src="images/1.gif" onClick="doRedirect('http://www.google.com')">
    </td>
    </tr>
    </table>
    </html>

  2. #2
    Nokia Developer Expert
    Join Date
    Jun 2008
    Location
    Tampere
    Posts
    833

    Re: 5800 widget redirect to other page problem

    Hello,

    When you use <a href=""> to switch between pages you will lose widget context. So after page switch window.widget no longer exists.
    See post #5 in this thread

    -Ilkka

Similar Threads

  1. Problem creating home screen widget
    By vijaygopal12345 in forum Symbian
    Replies: 4
    Last Post: 2009-05-15, 08:53
  2. STLPort namespace issue
    By yickhong in forum Open C/C++
    Replies: 0
    Last Post: 2009-04-09, 08:54
  3. Problem with player resuming at Nokia 5800
    By Asgard83 in forum Mobile Java Media (Graphics & Sounds)
    Replies: 2
    Last Post: 2008-12-11, 13:50
  4. Problem in displaying a Binary Setting Page
    By amey_symbian in forum Symbian
    Replies: 0
    Last Post: 2008-06-23, 10:16

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×