×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Dec 2009
    Posts
    4

    URLLIB HTTPLIB 1.9 for 5th Edition

    Hi everyone.

    Ive got a problem to connect over httplib/urllib with PyS60 1.9.4 .

    First i used PyS60 1.4.5 and everything works with this Code:

    for WLan:
    Code:
    stat=urllib.urlopen("http://micro-entertainment.pcuie.uni-due.de/getStopPoint.php?id="+str(self.foundPointID))
    aktstat=int(stat.read())
    stat.close()
    for GPRS-Connection:
    Code:
    conn = httplib.HTTPConnection(self.proxy)
    conn.request("POST", "http://micro-entertainment.pcuie.uni-due.de/getStopPoint.php?id="+str(self.foundPointID))
    response = conn.getresponse()
    aktstat= int(response.read())
    conn.close()
    Now i changed to 1.9.4 and both kinds of connections crash on the phone(Nokia 5800). I have to restart the phone to try again:-)

    I dont know what to do? I googled for a few hours but cant find a solution.
    Choosing an Access-Point is no Problem with btsocket.

    Thanks in advance.
    Last edited by Tutzi091; 2010-01-09 at 12:02.

  2. #2
    Registered User
    Join Date
    Dec 2009
    Posts
    4

    Re: Php Request 1.9 for 5th Edition

    Please help someone,

    ive got no idea how to solve this.

  3. #3
    Super Contributor
    Join Date
    Nov 2007
    Location
    Sertaozinho/Brazil
    Posts
    768

    Re: Php Request 1.9 for 5th Edition

    Hello Tutzi091

    I recommend a test using latest available version (1.9.7). If it fails as well the scape is to report as a bug at maemo or try to find the problem checking the pys60 source code or python base code. Additionally, you can try to use some python file from standard python distribution instead pys60. I did this sometimes to solve problems due to old version in pys60 1.4.5.

Similar Threads

  1. Replies: 2
    Last Post: 2009-07-07, 09:13
  2. Extended Panic Code in Series 60 Third Edition Emulator
    By razas in forum Symbian Tools & SDKs
    Replies: 6
    Last Post: 2007-08-17, 12:06
  3. TTime : TInt64& Int64() problem in S60 3rd edition
    By iulian_moldovan in forum Symbian Tools & SDKs
    Replies: 3
    Last Post: 2006-01-24, 13:07

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×