×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    Aug 2009
    Posts
    29

    Question Sensor framework

    I can run the application using sensor framework on 5th S60.But it can't be compiled on 3th FP2 S60.
    The error is as follow:

    #include <sensrvchannelfinder.h>
    #include <sensrvchannel.h>
    #include <sensrvmagnetometersensor.h>
    #include <sensrvgeneralproperties.h>
    #include <sensrvmagnetometersensor.h>
    #include <sensrvaccelerometersensor.h>
    #include <sensrvorientationsensor.h>
    #include <sensrvdatalistener.h>
    #include <sensrvtappingsensor.h>
    #include <sensrvilluminationsensor.h>
    #include <sensrvtypes.h>

    These files can't be opened.

    So what can I do for this? Please give me a favor.

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: Sensor framework

    that's bacause the 3rd ed FP2 SDK doe snot contain the headers or libraries needed for the sensor framework.

  3. #3
    Registered User
    Join Date
    Aug 2009
    Posts
    29

    Re: Sensor framework

    Quote Originally Posted by symbianyucca View Post
    that's bacause the 3rd ed FP2 SDK doe snot contain the headers or libraries needed for the sensor framework.
    I have found SensrvClient.lib and SensrvUtil.lib for it. But when I run it,there is an -2 system error thrown. So what libraries do I need to add ?

  4. #4
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: Sensor framework

    You can not copy libraries from newer SDKs, if you really need it for 3rd ed FP2, you can see whether it would be included in API plug-in, and if not, then you would need to go through API partnering in order to get it. Or you could try making Ecom plug-in with 5th ed SDK, and seeing whether it would work with 3rd ed FP2 devices.

  5. #5
    Registered User
    Join Date
    Aug 2009
    Posts
    29

    Re: Sensor framework

    Quote Originally Posted by symbianyucca View Post
    You can not copy libraries from newer SDKs, if you really need it for 3rd ed FP2, you can see whether it would be included in API plug-in, and if not, then you would need to go through API partnering in order to get it. Or you could try making Ecom plug-in with 5th ed SDK, and seeing whether it would work with 3rd ed FP2 devices.
    I have found Sensor API Plug-in for S60 3rd Edition SDK for Symbian OS, Feature Pack 2 ,and installed it.But the application throw the same error that is an -2 system error.

  6. #6
    Registered User
    Join Date
    Aug 2009
    Posts
    29

    Re: Sensor framework

    Quote Originally Posted by symbianyucca View Post
    You can not copy libraries from newer SDKs, if you really need it for 3rd ed FP2, you can see whether it would be included in API plug-in, and if not, then you would need to go through API partnering in order to get it. Or you could try making Ecom plug-in with 5th ed SDK, and seeing whether it would work with 3rd ed FP2 devices.
    I run the sensor API example that is provided by Nokia Corporation. And I install the plug_in and other Steps following the release. But there is the same error that is an -2 system error.

  7. #7
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: Sensor framework

    Where did you find the sersor framework ?
    And which example are you using ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×