×

Discussion Board

Results 1 to 13 of 13
  1. #1
    Registered User
    Join Date
    Feb 2008
    Location
    India, Nashik
    Posts
    816

    Emulator crashes ! - System Error -2

    Hi !

    I am running Qt for Symbian with Sdk 3rd ed. Fp1 also I have tried on 5th edition too, the project compiles well from Carbid.c++ 2.3.0 but when emulator is started it crashes with System error -2 , can anybody help me out ?

    Thanks
    Vishal

  2. #2
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Emulator crashes ! - System Error -2

    Do you start the emulator from command line or from IDE? Does it work when started standalone?
    If starting from IDE see http://wiki.forum.nokia.com/index.ph...arbide.c%2B%2B for some tips.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  3. #3
    Registered User
    Join Date
    Feb 2008
    Location
    India, Nashik
    Posts
    816

    Re: Emulator crashes ! - System Error -2

    Quote Originally Posted by ltomuta View Post
    Do you start the emulator from command line or from IDE? Does it work when started standalone?
    If starting from IDE see http://wiki.forum.nokia.com/index.ph...arbide.c%2B%2B for some tips.
    I have run the emulator from Carbid as well as externally when i run the application from within the carbid the emulator doesnt start and i can see carbid saying emulator terminated.

    When i run emulator standalone and run the application from emulator installed apps menu the application terminates giving System Error -2 , also I am able to run symbian c++ application with no problem this is only with Qt apps.


    Thanks

    Vishal

  4. #4
    Registered User
    Join Date
    Feb 2008
    Location
    India, Nashik
    Posts
    816

    Re: Emulator crashes ! - System Error -2

    Has anybody encountered this error ? While running Qt programs ?

  5. #5
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Emulator crashes ! - System Error -2

    Have you applied the needed patch to the Nokia C/C++ Compiler (CW)? Have you replaced the getexports.exe with the new one provided by Qt?
    http://pepper.troll.no/s60prereleases/patches/
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  6. #6
    Registered User
    Join Date
    Feb 2008
    Location
    India, Nashik
    Posts
    816

    Re: Emulator crashes ! - System Error -2

    Quote Originally Posted by ltomuta View Post
    Have you applied the needed patch to the Nokia C/C++ Compiler (CW)? Have you replaced the getexports.exe with the new one provided by Qt?
    http://pepper.troll.no/s60prereleases/patches/
    I have done that , when i tried running the example from command line i got a dll related error "efsrv.dll"ot found, how to tackle this ? I think if i can run from command line then it will also run from Carbid.

    -Vishal

  7. #7
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Emulator crashes ! - System Error -2

    Can you post that output here, so that I can understand the context? I can't as of now immagine any case in which the application would explicitely complain about a missing DLL. Which DLL I immagine does exist in the SDK.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  8. #8
    Super Contributor
    Join Date
    Nov 2009
    Location
    Minnesota, USA
    Posts
    3,209

    Re: Emulator crashes ! - System Error -2

    Quote Originally Posted by vdharankar View Post
    When i run emulator standalone and run the application from emulator installed apps menu the application terminates giving System Error -2 , also I am able to run symbian c++ application with no problem this is only with Qt apps.
    It sounds like you're telling Carbide debug to start the application (which for some crazy reason is the default) rather than having it start the emulator. Edit the debug config for your application to make it start "epoc.exe" rather than "my_application.exe" (same directory). Then start the emulator, navigate to the application, and start it (from the emulated application menu).

    If the application then crashes in a way that doesn't give you reasonable diagnostics, simply start it again but set a breakpoint near the beginning and step through it.

  9. #9
    Registered User
    Join Date
    Feb 2008
    Location
    India, Nashik
    Posts
    816

    Re: Emulator crashes ! - System Error -2

    Quote Originally Posted by danhicksbyron View Post
    It sounds like you're telling Carbide debug to start the application (which for some crazy reason is the default) rather than having it start the emulator. Edit the debug config for your application to make it start "epoc.exe" rather than "my_application.exe" (same directory). Then start the emulator, navigate to the application, and start it (from the emulated application menu).

    If the application then crashes in a way that doesn't give you reasonable diagnostics, simply start it again but set a breakpoint near the beginning and step through it.
    Dear friend ,

    I have done both the things and was not successful, even tried debugging but i found that it even didnt enter into main (when i set breakpoint to main). Only what i got was System Error -2 which doenst really say anything.

    Thanks

    -Vishal

  10. #10
    Super Contributor
    Join Date
    Nov 2009
    Location
    Minnesota, USA
    Posts
    3,209

    Re: Emulator crashes ! - System Error -2

    You might simply try starting the app several times, or doing some other things on the emulator and coming back and then starting the app. Epoc is pretty flaky and probably has some uninitialized variables or some such that seem to cause random errors.

  11. #11
    Registered User
    Join Date
    Feb 2008
    Location
    India, Nashik
    Posts
    816

    Re: Emulator crashes ! - System Error -2

    Quote Originally Posted by danhicksbyron View Post
    You might simply try starting the app several times, or doing some other things on the emulator and coming back and then starting the app. Epoc is pretty flaky and probably has some uninitialized variables or some such that seem to cause random errors.
    Well, I dont think so , but will try and if you are correct then will bang my head against wall

  12. #12
    Super Contributor
    Join Date
    Nov 2009
    Location
    Minnesota, USA
    Posts
    3,209

    Re: Emulator crashes ! - System Error -2

    I've got a pretty good dent in the wall right here.

  13. #13
    Registered User
    Join Date
    Feb 2008
    Location
    India, Nashik
    Posts
    816

    Re: Emulator crashes ! - System Error -2

    Hello evryone who tried helping me especially "Itomuta" thanks for all the help I must tell that i was able to run Qt in Carbide.c++ on 3rd edition Fp1, I m really happy to see the opened door of new world.

    Well must tell the mistake, i was not overwriting the "env_switch" folder containts from the patch which Itomuta mentioned.

    Regards
    Vishal

Similar Threads

  1. Is there anybody know file system filter in S60_3rd?
    By zhangwei_Nirvana in forum Symbian
    Replies: 5
    Last Post: 2008-04-26, 07:06
  2. Replies: 13
    Last Post: 2008-01-04, 11:15
  3. HELP !auto-reply sms system (using 8250 & VB6)
    By dancingqueeneng in forum PC Suite API and PC Connectivity SDK
    Replies: 4
    Last Post: 2007-02-08, 07:08
  4. Drawing in system area(the part draws battery&radio signal)
    By toughworker in forum Symbian User Interface
    Replies: 2
    Last Post: 2004-12-22, 01:28
  5. System Help with nokia pc connectivity SDK
    By gotka in forum PC Suite API and PC Connectivity SDK
    Replies: 4
    Last Post: 2004-07-06, 09:56

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×