×

Discussion Board

Results 1 to 9 of 9
  1. #1
    Registered User
    Join Date
    Oct 2009
    Posts
    2

    SIP session interval settings in SIP VoIP 2.x Settings Application

    There is no SIP session interval settings in the SIP VoIP 2.x Settings Application for S60 devices that implement VoIP Release 2.2 or 2.3. Thus, there is no way to change the default SIP session interval of 3600. In the SIP VoIP 3.x Settings Application for S60 devices that implement VoIP Release 3.0 or 3.1 there is support for SIP session interval settings. I was wondering if anyone knows if the SIP session interval can be set on s60 devices that implement VoIP release 2.2 or 2.3? Or if the developer of the SIP VoIP 2.x Settings Application could add support for SIP session interval settings. Thanks.

  2. #2
    Nokia Developer Champion
    Join Date
    Mar 2003
    Posts
    4,104
    One way would be feed-backing about this directly to the VoIP team because I am not aware of an active expert in this section. However, I do not think there will be such an addition as this is a new feature of VoIP/SIP Release 3. Nevertheless, may I ask, why do you want to play around with that value?

  3. #3
    Registered User
    Join Date
    Oct 2009
    Posts
    2

    Re: SIP session interval settings in SIP VoIP 2.x Settings Application

    Quote Originally Posted by traud View Post
    One way would be feed-backing about this directly to the VoIP team because I am not aware of an active expert in this section. However, I do not think there will be such an addition as this is a new feature of VoIP/SIP Release 3. Nevertheless, may I ask, why do you want to play around with that value?
    Thanks for your feedback. When my E63 is connected to my VoIP provider and I move outside the range of my wireless network without manually disconnecting the VoIP client on the E63 first, my VoIP provider still thinks my phone is registered. When this happens and an incoming VoIP phone call is placed to my VoIP number my provider tries to connect the call but of course it can't be connected since I'm outside the range of my wireless network also the call wont failover properly to my cellular number (which my VoIP provider automatically does when my E63 is not registered). This problem will continue to happen until the next registration interval (currently 3600 seconds). Thus, I wanted to set the registration interval or session interval lower to minimize this problem. Of course I could avoid the problem all together by manually disconnecting the VoIP client on my E63 before going out of range of my wireless network but this is a little inconvenient and easy to forget to do.

  4. #4
    Nokia Developer Champion
    Join Date
    Mar 2003
    Posts
    4,104
    Because Nokia will not change anything, you should contact your provider and discuss this issue with them. They too have the possibility to lower the session reconnection interval, although I do not think this is a good solution in this case:
    Quote Originally Posted by ertw View Post
    the call wont failover properly to my cellular number
    Why, you should ask them.

  5. #5
    Registered User
    Join Date
    Mar 2010
    Posts
    12

    Lightbulb Re: SIP session interval settings in SIP VoIP 2.x Settings Application

    Hi everybody. I'm using the VoIP Release 3.x application, so I'm able to change the SIP session interval.
    In the help, all the information I get is that I can choose a value between 0 and 3600 and that the default is 1800.
    As this seems to be the only thread about this topic in all the internets, I thought I'd ask here:
    What value would you recommend?
    I'm planning to use a betamax service on my E52, both with WiFi and 3G.
    Thanks for your help.

  6. #6
    Nokia Developer Champion
    Join Date
    Mar 2003
    Posts
    4,104
    Quote Originally Posted by rjschenk View Post
    What value would you recommend?
    What do you want to achieve?

  7. #7
    Registered User
    Join Date
    Mar 2010
    Posts
    12

    Question Re: SIP session interval settings in SIP VoIP 2.x Settings Application

    Quote Originally Posted by traud View Post
    What do you want to achieve?
    Thanks for answering. Good question.
    Sometimes SIP profiles can't be registered and VoIP profiles can't be activated with no apparent reason. I was wondering if this could have something to do with the session interval and if yes, if there is a good reason to have such a long interval.

  8. #8
    Nokia Developer Champion
    Join Date
    Mar 2003
    Posts
    4,104
    You should analyse the reason with tools like Wireshark. If you are not in control of the SIP server, use a Wireless LAN access point which allows you to capture its traffic.

  9. #9
    Registered User
    Join Date
    Mar 2010
    Posts
    12

    Re: SIP session interval settings in SIP VoIP 2.x Settings Application

    Quote Originally Posted by traud View Post
    You should analyse the reason with tools like Wireshark. If you are not in control of the SIP server, use a Wireless LAN access point which allows you to capture its traffic.
    Thanks for pointing to the right direction, although I don't think I'll go there.
    Following a strict "don't fix it if it ain't broke"-policy has pretty much solved the problem already.
    Last edited by rjschenk; 2010-04-08 at 22:07.

Similar Threads

  1. Replies: 6
    Last Post: 2009-06-09, 12:11
  2. Provisioning gprs settings for j2me application?
    By homolupus in forum OMA DM/DS/CP
    Replies: 12
    Last Post: 2009-01-15, 18:29
  3. SIP content type
    By hlothman in forum Symbian Networking & Messaging (Closed)
    Replies: 8
    Last Post: 2006-05-17, 09:26
  4. Problem with SIP Plug-in for Series 60 SDK 2.0
    By jalakuri in forum Symbian Tools & SDKs
    Replies: 27
    Last Post: 2005-08-22, 09:55
  5. Adding new SIP profiles to SIP Settings?
    By jrantam in forum Symbian Tools & SDKs
    Replies: 0
    Last Post: 2005-03-02, 10:56

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •