×

Discussion Board

Results 1 to 4 of 4

Hybrid View

  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    17

    Icons display on emulator, but not on Nokia 7650. why?

    I've developed a Series 60 application, and am using Java 2 Micro Edition Wireless Toolkit from Sun to package the application into JAD and JAR files.

    In the emulator, all the graphics(icons etc.) load properly and show up on the emulator display during execution.

    However, when the software ios deployed to a Nokia 7650, the icons are non-existent, though the software behaves in a stable fashion.

    Help! whats the problem?

    are the icons not being packaged?
    Whats going on?

    Plz help, this is a software project for a BSc dissertation, due in in two weeks!

    any more details on the problem provided upon request.

    Thanks

  2. #2
    Registered User
    Join Date
    May 2003
    Location
    Zagreb, Croatia
    Posts
    8
    Howgh!

    Icon must be of 32x32 size (24bit color) PNG and the same name as the MIDlet class. So, if your class is MyClass, then icon should be named as MyClass.png. It should be positioned in /res directory (if you're using Wireless toolkit, you should have seen it).

    Regards, Stevica

  3. #3
    Regular Contributor
    Join Date
    Mar 2003
    Location
    Canada
    Posts
    101
    Icons do not need to be 32x32, 24-bit, or named the same as any class.

  4. #4
    Registered User
    Join Date
    May 2003
    Location
    Zagreb, Croatia
    Posts
    8
    You're right for the size and color depth, but (if one does not point Wireless toolkit other) Wireless toolkit loads icon with MIDlet class name on default for app icon.

    S.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×