×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Jan 2008
    Posts
    2

    E72 SIP audio delay

    first of all, sorry for my bad english :-)
    there is a delay (~300ms) in the incoming audio stream when using the built-in sip client. i've spent days figuring out its cause. tried with a local sip registrar ([e72] <--> [linksys spa921], both on the same lan) but the latency is the same. pings to the phone are in the 20ms range, so this couldn't be the source of the delay. i've played around with the codecs (g711, g729) and jitter buffer settings, and it didn't help either. my conclusion was that it must be the nokia sip stack which introduces the latency. then i installed fring and nimbuzz (i think they have a proprietary sip ipmlementation), same latency again... at last i wrote a simple j2me ping-like application to test the socket connection performance to my pc, and all the packets arrived in <30ms.
    do you have any ideas?

    btw, does anybody know if the engineers at nokia were smart enough making it possible to focus the camera when the optical navi key is disabled?

    greetings,
    peter

  2. #2
    Registered User
    Join Date
    Mar 2003
    Posts
    4,105
    Did you try another WLAN access point, too?
    Did you try: Nokia » Menu » Settings » Connection » WLAN » Options » Advanced settings » Automatic = Disabled » Power saving = Disabled?

  3. #3
    Registered User
    Join Date
    Jan 2008
    Posts
    2

    Re: E72 SIP audio delay

    sorry for the late answer...

    yes, i've tried both, but the delay is the same.

    thanks for your tip anyway!

  4. #4
    Registered User
    Join Date
    Feb 2009
    Posts
    1

    Re: E72 SIP audio delay

    I'm having the same issue. I've tested extensivley via 3G, and there is a noticable delay in the recieved audio compared with the transmitted audio. Tested using G729 and ilbc connecting to an asterisk server, all public IPs, with good network conditions. Also tried connecting directly with a SIP provider with the same problem.

    Tried changing the jitter buffer, reducing it to 100ms but it doesn't help much. It's also interesting to note, that when the jitter buffer is set to less than about 60ms, the phone rejects incoming calls with a 500 Internal server error (according to the SIP debug on the asterisk server side) and doesn't ring (with all the Codecs I've tried).

    The delay is the biggest problem, however. If the other party is on a cell phone, the additional delay makes the phone unusable for regular conversations.

    I've also tried Nimbuzz as a comparision, and the delay also appears there also. I have an E72-2 NAM, product code 0573646, firmware 22.007.

    Could a Nokia rep please comment? The inbuilt VoIP was the reason for phone purchase, and with this delay is useless for VoIP calls.

  5. #5
    Registered User
    Join Date
    Apr 2009
    Posts
    2

    Re: E72 SIP audio delay

    Quote Originally Posted by msalkeld View Post
    I'm having the same issue. I've tested extensivley via 3G, and there is a noticable delay in the recieved audio compared with the transmitted audio. Tested using G729 and ilbc connecting to an asterisk server, all public IPs, with good network conditions. Also tried connecting directly with a SIP provider with the same problem.

    Tried changing the jitter buffer, reducing it to 100ms but it doesn't help much. It's also interesting to note, that when the jitter buffer is set to less than about 60ms, the phone rejects incoming calls with a 500 Internal server error (according to the SIP debug on the asterisk server side) and doesn't ring (with all the Codecs I've tried).

    The delay is the biggest problem, however. If the other party is on a cell phone, the additional delay makes the phone unusable for regular conversations.

    I've also tried Nimbuzz as a comparision, and the delay also appears there also. I have an E72-2 NAM, product code 0573646, firmware 22.007.

    Could a Nokia rep please comment? The inbuilt VoIP was the reason for phone purchase, and with this delay is useless for VoIP calls.
    I add, seen I have the same prob.

    Could a Nokia rep please comment?

    Could a Nokia rep please comment? again?
    Last edited by stingnokia; 2010-04-16 at 22:10. Reason: no one answering, and wish an answer

Similar Threads

  1. Missing VoIP bridge to SIP client in E72
    By mthulin in forum VoIP
    Replies: 3
    Last Post: 2010-01-21, 15:49
  2. Resolverplugin replies message 401
    By dimaar in forum Symbian Networking & Messaging (Closed)
    Replies: 10
    Last Post: 2008-12-10, 17:09
  3. Making a SIP audio / video call from Nokia to PC
    By jkorycki in forum Mobile Java Tools & SDKs
    Replies: 2
    Last Post: 2008-09-23, 10:11
  4. Video with audio recording delay problem on N90
    By vasya0 in forum Symbian Media (Closed)
    Replies: 2
    Last Post: 2007-12-03, 16:44
  5. SIP Client requires Audio Codecs?
    By ravindimantha in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2006-03-08, 05:26

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×