×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 18
  1. #1
    Registered User
    Join Date
    Apr 2008
    Posts
    35

    device object missing on N97?

    Users keep reporting problems with my widget. According to the log, on their device there is so "device" object which I use to access the calendar service. Here is the code I use:

    Code:
    	try {
    		// call calendar service
    		if (device != "undefined")
    			calendarService = device.getServiceObject("Service.Calendar", "IDataSource");
    		else
    			throw('device object does not exist');
    	} catch(e) {
    		error('loading Calendar service: ' + e + ', line ' + e.line);
    		return;
    	}
    And this is the error message _some_ N97 users get:
    Error: loading Calendar service:
    ReferenceError: Can't find variable:
    device, line 664
    I'm puzzled. I could not find anything in the docs that would explain why the device object would not be available. On the other hand, I can't reproduce this problem on my own N97. This problems seems to occure only on very few devices. Any help would be appreciated.

  2. #2
    Nokia Developer Expert
    Join Date
    Jun 2008
    Location
    Tampere
    Posts
    833

    Re: device object missing on N97?

    Hello,

    I have not heard about this kind of problem before.

    Is there any change, that you could contact the users that have encountered these problems and ask what is their software version?
    Or have they been able to solve the problem by updating the phone software?

    -Ilkka

  3. #3
    Registered User
    Join Date
    Sep 2008
    Location
    Manaus, Brazil
    Posts
    109

    Re: device object missing on N97?

    Problem is your software version. What's the version?
    Javier Zambrano Ferreira

  4. #4
    Registered User
    Join Date
    Apr 2008
    Posts
    35

    Re: device object missing on N97?

    The firmware is version 20.0.019 which is the latest available (Optus carrier branded).

  5. #5
    Registered User
    Join Date
    Apr 2008
    Posts
    35

    Re: device object missing on N97?

    Just got another user report with the same problem, also FW 2.1 (french).

  6. #6
    Registered User
    Join Date
    Feb 2010
    Posts
    2

    Re: device object missing on N97?

    I also have this problem while trying to use API 2.0 on my N97

    I use firmware v21.0.045 14-01-10 RM-505


    update: it seems to work ok when you use com.nokia.device

    update: unfortunately, it does not work. problem still exists
    Last edited by robhaverkort; 2010-03-03 at 07:39.

  7. #7
    Registered User
    Join Date
    Apr 2008
    Posts
    35

    Re: device object missing on N97?

    Sorry robhaverkort, but there is neither a com nor a nokia object (at least in the emulator).

  8. #8
    Registered User
    Join Date
    Feb 2010
    Posts
    2

    Re: device object missing on N97?

    no, it doesnt work on my n97 either.

    Did you try to run the example-widgets that come with the platformservices-package ?

    They use com.nokia.device

  9. #9
    Registered User
    Join Date
    Apr 2010
    Posts
    1

    Question Re: device object missing on N97?

    same problem here, I have a Nokia N78 version 30.011.051.1
    ReferenceError - Can't find variable: device
    Same with com.nokia.device and nokia.device .

    I've updated my phone, it's up to date.

  10. #10
    Registered User
    Join Date
    May 2004
    Location
    Singapore
    Posts
    5

    Re: device object missing on N97?

    Thought you'll like to know I encountered the same problem with the above widget after upgrading my Nokia N8 to firmware 1.1...

  11. #11
    Registered User
    Join Date
    Apr 2008
    Posts
    35

    Re: device object missing on N97?

    The problem seems to be related to a (probably) corrupted symbian configuration file located in C:\Private\2000f847. If this file is replaced by the default file (http://sourceforge.net/tracker/downl...28&aid=2956758), the error goes away. You need to hack your phone or completely reset it in order to repair that file though. For more details, please refer to http://sourceforge.net/tracker/?func...6&atid=1175663.

  12. #12
    Registered User
    Join Date
    May 2004
    Location
    Singapore
    Posts
    5

    Angry Re: device object missing on N97?

    Yes, I saw that thread and followed it here actually. However I don't have a hacked N8 and is unwilling to do a hard reset. At any rate, I "solved" the issue by restoring application settings from a backup done just prior to doing the firmware upgrade.
    Last edited by whjou; 2011-03-19 at 19:50.

  13. #13
    Registered User
    Join Date
    Nov 2010
    Posts
    33

    Re: device object missing on N97?

    i'm having this problem on my n8 - it appeared after i installed qt 4.7.2 + the new qtmobility & qtwebkit, tho' i'm not sure it's related
    i've since updated to pr1.2, but that didn't help any

    i can't seem to find an option to reset application settings (i guess factory setttings under phone management does this - what else does it clear?)
    i also can't seem to find anything clear on what needs to be done to gain root access to the phone, so i could try simply replacing the files in C:\Private\2000f847 ?

  14. #14
    Nokia Developer Expert
    Join Date
    Jun 2008
    Location
    Tampere
    Posts
    833

    Re: device object missing on N97?

    Hi,

    Problem reported to R&D, they will investigate this further. I'll let you know, if there is any updates.

    Br,
    Ilkka

  15. #15
    Registered User
    Join Date
    Apr 2008
    Posts
    35

    Re: device object missing on N97?

    Any news on this? It's embarrassing tell my users that they have to reset their entire phone to get rid of this error.

Similar Threads

  1. N97 fail to restore the backup after went to Nokia Service Center refresh firmware.
    By alan_ckl in forum Series 40 & S60 Platform Feedback Archive
    Replies: 1
    Last Post: 2009-12-17, 09:13
  2. PROBLEM WITH NOKIA N97
    By fairulamir in forum General Development Questions
    Replies: 2
    Last Post: 2009-11-06, 03:08
  3. 1 Frozen Export(s) missing from object files
    By jmeasow in forum Symbian
    Replies: 7
    Last Post: 2007-07-09, 12:33
  4. Missing device property: default_image (Nokia-3300)
    By mortengh in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2003-10-22, 09:34

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×