×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Feb 2010
    Posts
    1

    How to loop a sound seamlessly (no silent gaps)

    Hi all,
    Thank you for reading this. I want to play a .wav file in a loop, to create an audio background but i have not been successful. I have tried CMdaAudioPlayerUtility and the MapcPlayComplete callback, but there is a big silent gap in between rounds.
    Have also tried CMdaAudioOutputStream, but have not succeded...
    Anyone, please help. It is a bit urgent.

  2. #2
    Nokia Developer Expert
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,143

    Re: How to loop a sound seamlessly (no silent gaps)

    CMdaAudioOutputStream would propably be the best option, since then you could read the files and keep on adding teh buffers in loop to the player, other ones you would need to get the play ended event and then start playing again.

  3. #3
    Super Contributor
    Join Date
    Jul 2008
    Posts
    2,020

    Re: How to loop a sound seamlessly (no silent gaps)

    Sorry to say so but I feel Jukka is right. I have done some testing with MDAAudioRecorder,and did not manage to eliminate the gasp completely for MP3 files so far.

    I will still play around a bit more, but generally think that the direct buffer is the only workable way...
    The lines above are the best I have to offer.If anyone of you is of more advanced knowledge, I ask for your patience and understanding! - unknown arab poet
    http://www.tamoggemon.com - Symbian blog - Windows Phone blog
    My other blogs:
    webOS blog iPhone blog BlackBerry blog Samsung bada blog Android blog

  4. #4
    Super Contributor
    Join Date
    Jul 2008
    Posts
    2,020

    Re: How to loop a sound seamlessly (no silent gaps)

    An update: the Sound Mixer example v2.1 provides a GREAT way to do this. But, you need to use WAV files only and stay below the 25 to 30sec boundary per file!!
    The lines above are the best I have to offer.If anyone of you is of more advanced knowledge, I ask for your patience and understanding! - unknown arab poet
    http://www.tamoggemon.com - Symbian blog - Windows Phone blog
    My other blogs:
    webOS blog iPhone blog BlackBerry blog Samsung bada blog Android blog

Similar Threads

  1. Replies: 7
    Last Post: 2009-06-18, 21:05
  2. Replies: 0
    Last Post: 2008-06-17, 12:21
  3. Problem with Sound class getState()
    By creepymo in forum Mobile Java Media (Graphics & Sounds)
    Replies: 1
    Last Post: 2005-06-20, 18:43
  4. RunL() method is not being called
    By dotcdotc in forum Symbian C++
    Replies: 9
    Last Post: 2004-12-13, 11:25
  5. MIDI Sound problem (J2ME / Series 60)
    By JPapke in forum Mobile Java Media (Graphics & Sounds)
    Replies: 2
    Last Post: 2004-10-29, 08:17

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •