×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Regular Contributor
    Join Date
    Aug 2009
    Posts
    260

    Carbide C/C++ Symbian Parser Problem

    In my ContainerView.cpp file I have methods SetupStatusPaneL and CleanupStatusPane that are said to be missing yet they are there. It seems the parser gets confused and messes up the file. Any idea on how to correct this.

  2. #2
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,344

    Re: Carbide C/C++ Symbian Parser Problem

    Quote Originally Posted by neverma View Post
    In my ContainerView.cpp file I have methods SetupStatusPaneL and CleanupStatusPane that are said to be missing yet they are there. It seems the parser gets confused and messes up the file. Any idea on how to correct this.
    Can you elaborate more about your problem? What are the errors? And when do you get them?
    Nokia Developer Wiki Moderation team

  3. #3
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Carbide C/C++ Symbian Parser Problem

    Quote Originally Posted by neverma View Post
    In my ContainerView.cpp file I have methods SetupStatusPaneL and CleanupStatusPane that are said to be missing yet they are there. It seems the parser gets confused and messes up the file. Any idea on how to correct this.
    is this class is written by you or generated by UI Designer ?

  4. #4
    Regular Contributor
    Join Date
    Aug 2009
    Posts
    260

    Re: Carbide C/C++ Symbian Parser Problem

    It's generated by UI Designer. When i try to modify the view that's when it did this. it has done it several times before. i think it has got serious bug.

  5. #5
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Carbide C/C++ Symbian Parser Problem

    Quote Originally Posted by neverma View Post
    It's generated by UI Designer. When i try to modify the view that's when it did this. it has done it several times before. i think it has got serious bug.
    No that is not a bug. you are facing the problem as you are adding your code where it says
    // [[[ begin generated region: do not modify [Generated Constants]
    // ]]] end generated region [Generated Constants]

  6. #6
    Regular Contributor
    Join Date
    Aug 2009
    Posts
    260

    Re: Carbide C/C++ Symbian Parser Problem

    I have not added any code in that region. I mean when I try to add control to the UI design/view that's when i got this error. The functions are there in code and it's still popping this error:

    C/C++ parser cannot find 'function(CSymantecInstructionsContainerView::CleanupStatusPane())' in 'src/SymantecInstructionsContainerView.cpp'; check the immediate area for syntax errors (id 'CLEANUPSTATUSPANE_METHOD', component 'com.nokia.sdt.series60.CAknView') SymantecInstructionsContainerView.cpp SymantecV3FP1/src Unknown Carbide.c++ UI Designer Message Marker

  7. #7
    Nokia Developer Champion
    Join Date
    May 2004
    Posts
    2,267

    Re: Carbide C/C++ Symbian Parser Problem

    Hi,

    Sometimes the UI designer just messes things up, and the workaround I used to solve the issue is:

    1. make a backup of the project then remove it from the Carbide.c++ workspace.
    2. use UI designer to re-create the project (with the same name and UID), and then re-do the UI designs, and then save the work.
    3. compare the old project to the new project (f.e. by Beyond Compare), and then merge my code to the new project.

    Regards

    Ziteng Chen

  8. #8
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Carbide C/C++ Symbian Parser Problem

    i have never faced this in last one year. But if it is still happening regularly then we must submit a Bug to Carbide.c++ development team.

Similar Threads

  1. Problem with Carbide + Symbian SDK on Vista
    By jpolvi1 in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 3
    Last Post: 2009-11-09, 20:51
  2. Problem with Carbide Express in Win Vista
    By kartee_g in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 16
    Last Post: 2008-11-06, 09:50
  3. Carbide C++ 1.2 License Problem
    By meihao in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 6
    Last Post: 2008-02-28, 21:20
  4. Carbide symbian 9.1 application problem
    By Magrip in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2006-09-06, 15:26
  5. web services on symbian...problem won't be resolved!!!
    By ashrafabdoh in forum Symbian Networking & Messaging (Closed)
    Replies: 2
    Last Post: 2005-09-16, 14:59

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×