×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Feb 2010
    Posts
    31

    Flash lite api bridge - capture image problem

    Hi

    i am trying to get photo capture using flash lite api bridge but the captured imade does not load into the app.
    The image path loads in fine. I have added a loaderror listener and it returns url cannot be found.

    The bridge is working as it access camera
    i am wrapping in wrt and packaging as sis
    im using a n95 with latest firmware

    any ideas?
    Thx in advance
    ade

  2. #2
    Nokia Developer Champion
    Join Date
    Jul 2008
    Location
    Pakistan
    Posts
    1,065

    Smile Re: Flash lite api bridge - capture image problem

    Just do a quick test. Browse to the path of image returned by Api Bridge Camera plugin by using file explorer & check out whether this path & image really exist ? If the path doesnt exist then create it via file explorer.

    Best Regards,
    SajiSoft

  3. #3
    Registered User
    Join Date
    Feb 2010
    Posts
    31

    Re: Flash lite api bridge - capture image problem

    Hi

    Ok I have checked the path that is dumped out after the image is taken. It appears to be correct.

    c:\Data\Images\201002\201002A0\22022010022.jpg

    The only difference is that my nokia file explorer shows c:\ as phone memory. but other than that the actual path is correct.

    any further ideas on where i could be going wrong?

  4. #4
    Nokia Developer Champion
    Join Date
    Jul 2008
    Location
    Pakistan
    Posts
    1,065

    Smile Re: Flash lite api bridge - capture image problem

    Quote Originally Posted by kinski76 View Post
    Hi

    Ok I have checked the path that is dumped out after the image is taken. It appears to be correct.

    c:\Data\Images\201002\201002A0\22022010022.jpg

    The only difference is that my nokia file explorer shows c:\ as phone memory. but other than that the actual path is correct.

    any further ideas on where i could be going wrong?
    Its quite strange i.e the image exists & path is correct but even it is not loading the image for u.What is the exact error u r getting then? However, double check that u have loadMovie statement after extracting values from the returned variables i.e something like this :
    Code:
    var outList = outParam.ReturnValue;
    var Src = outList.Src;
    txtOutput.text = Src;
    photo.loadMovie(Src); //where photo is simply a movie clip.
    Moreover, first try it in standalone flash player then in WRT. Because doing so help us to detect whether it is a WRT related issue or Flash Lite.

    Best Regards,
    SajiSoft

  5. #5
    Registered User
    Join Date
    Feb 2010
    Posts
    31

    Re: Flash lite api bridge - capture image problem

    Hi Thanks for the reply. I will do some more testing in the morning.

    The error I get is "URL not found".

    thanks again

Similar Threads

  1. Flash Lite 3.0 API Application Development using ActionScript2.0
    By emailme.friend in forum [Archived] Flash Lite on Nokia Devices
    Replies: 11
    Last Post: 2009-11-05, 13:29
  2. load image problem
    By Pmarcoen in forum Mobile Java Media (Graphics & Sounds)
    Replies: 2
    Last Post: 2009-08-23, 06:19
  3. S60 3rd Edition - IMEI retrival via Flash Lite
    By mikebrant in forum [Archived] Flash Lite on Nokia Devices
    Replies: 1
    Last Post: 2008-03-05, 23:55
  4. Flash lite problem on nokia 6288
    By windowsxp168 in forum Series 40 & S60 Platform Feedback Archive
    Replies: 17
    Last Post: 2007-02-23, 09:22
  5. Image Problem
    By Spider_Eg in forum Mobile Java General
    Replies: 2
    Last Post: 2007-01-30, 13:52

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×