×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Nokia Developer Expert
    Join Date
    Jun 2009
    Posts
    36

    Question dialogtest2 and Q_WS_MAEMO_5

    Hi,

    This is a simple question but Iḿ still a newbie on QT for maemo.

    The dialogtest2 programme demonstrating stacked windows on Kate Alholaś blog compiles fine in QT Creator and the ARMEL scratchbox but fails in the x86 scratchbox with the message:

    g++ -c -pipe -O2 -Wall -W -D_REENTRANT -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED -I/targets/FREMANTLE_X86/opt/qt4-maemo5/mkspecs/linux-g++ -I. -I/targets/FREMANTLE_X86/opt/qt4-maemo5/include/QtCore -I/targets/FREMANTLE_X86/opt/qt4-maemo5/include/QtGui -I/targets/FREMANTLE_X86/opt/qt4-maemo5/include -I. -I. -o mymainwindow.o mymainwindow.cpp
    mymainwindow.cpp:12:43: error: QtMaemo5/QMaemo5KineticScroller: No such file or directory
    mymainwindow.cpp: In member function 'void MyMainWindow::SetupDialog()':
    mymainwindow.cpp:64: error: expected type-specifier before 'QMaemo5KineticScroller'
    mymainwindow.cpp:64: error: expected `;' before 'QMaemo5KineticScroller'
    make: *** [mymainwindow.o] Error 1

    This seems to be because Q_WS_MAEMO_5 is defined in both contexts. How do I ensure this is not defined by default in X86 scratchbox?

    Iḿ using latest scratchbox SDK which I assume is 4.6.2 having reinstalled libqt4-maemo5-dev a few days ago.

    PS Can esbox be used to build qt projects?

    Many thanks,
    David

  2. #2
    Super Contributor
    Join Date
    Oct 2009
    Posts
    4,326

    Re: dialogtest2 and Q_WS_MAEMO_5

    Quote Originally Posted by davidmct View Post
    The dialogtest2 programme demonstrating stacked windows on Kate Alholaś blog compiles fine in QT Creator and the ARMEL scratchbox but fails in the x86 scratchbox...
    Which means that you have different versions of Qt in armel and x86 targets.

    Quote Originally Posted by davidmct View Post
    with the message:
    mymainwindow.cpp:12:43: error: QtMaemo5/QMaemo5KineticScroller: No such file or directory
    QMaemo5KineticScroller was removed from Qt 4.6.1. Kate's code now is outdated.
    You could learn that from here:
    http://discussion.forum.nokia.com/fo...d.php?t=189793
    or here:
    http://labs.trolltech.com/blogs/2010...-5-going-beta/

    Quote Originally Posted by davidmct View Post
    This seems to be because Q_WS_MAEMO_5 is defined in both contexts. How do I ensure this is not defined by default in X86 scratchbox?
    How did you come to this conclusion?

    Quote Originally Posted by davidmct View Post
    Iḿ using latest scratchbox SDK which I assume is 4.6.2 having reinstalled libqt4-maemo5-dev a few days ago.
    Why don't you check it with dpkg?

    Quote Originally Posted by davidmct View Post
    PS Can esbox be used to build qt projects?
    Yes, it can.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •