×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Mar 2003
    Location
    Luttenberg (Netherlands)
    Posts
    577

    Problem with RSyncMLDataSyncJob

    Hi,

    I am doing a SyncML project. If I have:

    iSyncJob.CreateL( iSyncMLSession, profileId );

    in my code, it will crash on FP2 phones (reproduced on 6220c and E75). Although it should be possible to use this API using only the 2 parameters provided, it does not work. The code below works for me:

    RArray<TSmlTaskId> tasks(1);
    CleanupClosePushL( tasks );
    iSyncJob.CreateL( iSyncMLSession, profileId, ESmlTwoWay, tasks );
    CleanupStack::PopAndDestroy( &tasks );

    but I do not get a "Unknown command" notification during synchronisation. Probably because the provided array does not have an initialized task.

    My question here is: is it a known issue that the iSyncJob.CreateL( iSyncMLSession, profileId ) does not work?

    BR,

    Rene
    Rene Heuven
    Inmote - Creative Smartphone Solutions
    Web: www.inmote.com
    E-mail: rene@inmote.com

  2. #2
    Registered User
    Join Date
    Mar 2003
    Location
    Luttenberg (Netherlands)
    Posts
    577

    Re: Problem with RSyncMLDataSyncJob

    Hi,

    I have updated my workaround code to:

    TSmlTaskId taskId = FindTaskIdL( profileId );

    RArray<TSmlTaskId> rTaskArray;
    CleanupClosePushL( rTaskArray );
    rTaskArray.Append( taskId );
    iSyncJob.CreateL( iSyncMLSession, profileId, ESmlTwoWay, rTaskArray );
    CleanupStack::PopAndDestroy( &rTaskArray );

    which seems to work. The "unknown command" notification is not related. It turned out it came from my code in HandleCommandL() accidentally.

    Nonetheless, question remains:

    Is it a known issue that the iSyncJob.CreateL( iSyncMLSession, profileId ) does not work?

    BR,

    Rene
    Rene Heuven
    Inmote - Creative Smartphone Solutions
    Web: www.inmote.com
    E-mail: rene@inmote.com

Similar Threads

  1. STLPort namespace issue
    By yickhong in forum Open C/C++
    Replies: 0
    Last Post: 2009-04-09, 08:54
  2. SyncML link problem
    By samuel_ in forum Symbian
    Replies: 4
    Last Post: 2009-03-27, 08:02
  3. Problem with eglSwapBuffers and heap corruption
    By greatape in forum Symbian Media (Closed)
    Replies: 2
    Last Post: 2007-05-24, 03:35
  4. netcards - Problem with opening adapter
    By kernj in forum Symbian Tools & SDKs
    Replies: 5
    Last Post: 2007-01-10, 08:56
  5. Problem: S60 SDK for CW in PC with .NET
    By anttij in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2005-02-28, 11:36

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×